diff mbox series

[bug#48217,v2,7/9] gnu: Add mbelib.

Message ID 20210505084824.22275-7-glv@posteo.net
State Accepted
Headers show
Series [bug#48217,v2,1/9] gnu: Add csdr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Guillaume Le Vaillant May 5, 2021, 8:48 a.m. UTC
* gnu/packages/audio.scm (mbelib): New variable.
---
 gnu/packages/audio.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index da67f78fd0..d8e4be37fa 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -29,7 +29,7 @@ 
 ;;; Copyright © 2019 Hartmt Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2020 Jonathan Frederickson <jonathan@terracrypt.net>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
@@ -5036,6 +5036,31 @@  digital radio.")
     (home-page "https://www.rowetel.com/?page_id=452")
     (license license:lgpl2.1)))
 
+(define-public mbelib
+  ;; No release since 2016, use commit directly.
+  (let ((commit "9a04ed5c78176a9965f3d43f7aa1b1f5330e771f")
+        (revision "1"))
+    (package
+      (name "mbelib")
+      (version "1.3.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/szechyjs/mbelib")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0a7xmf87xnjzm5b437j2vnwv39x0ascja1j04c5wj6xs1529gw8h"))))
+      (build-system cmake-build-system)
+      (home-page "https://github.com/szechyjs/mbelib")
+      (synopsis "P25 Phase 1 and ProVoice vocoder")
+      (description
+       "The mbelib library provides support for the 7200x4400 bit/s codec used
+in P25 Phase 1, the 7100x4400 bit/s codec used in ProVoice and the @emph{Half
+Rate} 3600x2250 bit/s vocoder used in various radio systems.")
+      (license license:bsd-0))))
+
 (define-public ableton-link
   (package
     (name "ableton-link")