diff mbox series

[bug#48217,2/9] gnu: Add serialdv.

Message ID 20210504085705.5298-2-glv@posteo.net
State Accepted
Headers show
Series Add sdrangel | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Guillaume Le Vaillant May 4, 2021, 8:56 a.m. UTC
* gnu/packages/radio.scm (serialdv): New variable.
---
 gnu/packages/radio.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 382fdf85e3..63088394bf 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1629,3 +1629,26 @@  defined radio with support for rtl-sdr.")
 @acronym{SDRs, Software Defined Radios}, and the @code{csdr} command line
 program that can be used to build simple signal processing flow graphs.")
       (license license:gpl3+))))
+
+(define-public serialdv
+  (package
+    (name "serialdv")
+    (version "1.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/f4exb/serialDV")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0d88h2wjhf79nisiv96bq522hkbknzm88wsv0q9k33mzmrwnrx93"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))  ; No test suite.
+    (home-page "https://github.com/f4exb/serialDV")
+    (synopsis "Audio interface for AMBE3000 based devices")
+    (description
+     "SerialDV is a minimal interface to encode and decode audio with AMBE3000
+based devices in packet mode over a serial link.")
+    (license license:gpl3+)))