diff mbox series

[bug#48159] gnu: pioneers: Patch path to beep.

Message ID 20210502124112.16882-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#48159] gnu: pioneers: Patch path to beep. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder May 2, 2021, 12:41 p.m. UTC
Fixes <https://issues.guix.gnu.org/47131>

* gnu/packages/games.scm (pioneers): Patch path to beep.
[inputs]: Add beep.
[arguments]: Add phase patch-beep-path.
---
 gnu/packages/games.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Ludovic Courtès May 3, 2021, 4:03 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> skribis:

> Fixes <https://issues.guix.gnu.org/47131>
>
> * gnu/packages/games.scm (pioneers): Patch path to beep.
> [inputs]: Add beep.
> [arguments]: Add phase patch-beep-path.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..efdf4b4edb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4700,7 +4700,18 @@  are only two levels to play with, but they are very addictive.")
                (base32
                 "07b3xdd81n8ybsb4fzc5lx0813y9crzp1hj69khncf4faj48sdcs"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Fixes https://issues.guix.gnu.org/47131.
+         (add-after 'unpack 'patch-beep-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "client/gtk/audio.c"
+               (("\"beep\"")
+                (string-append "\"" (assoc-ref inputs "beep") "/bin/beep\"")))
+             #t)))))
     (inputs `(("avahi" ,avahi)
+              ("beep" ,beep)
               ("gtk+" ,gtk+)
               ("librsvg" ,librsvg)))
     (native-inputs `(("intltool" ,intltool)