diff mbox series

[bug#48158] gnu: xboard: Patch path to aplay.

Message ID 20210502114620.4133-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#48158] gnu: xboard: Patch path to aplay. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder May 2, 2021, 11:46 a.m. UTC
Fixes <http://issues.guix.gnu.org/47195>.

* gnu/packages/games.scm (xboard): Patch path to aplay.
[inputs]: Add alsa-utils.
[arguments]: Add phase patch-aplay-path.
---
 gnu/packages/games.scm | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès May 3, 2021, 4:02 p.m. UTC | #1
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

> Fixes <http://issues.guix.gnu.org/47195>.
>
> * gnu/packages/games.scm (xboard): Patch path to aplay.
> [inputs]: Add alsa-utils.
> [arguments]: Add phase patch-aplay-path.

Applied, thanks!

Incidentally, the following still breaks on the first move:

  $ guix environment --ad-hoc xboard -- xboard
  […]
  xboard: Error writing to first chess program: Broken pipe

At first sight the reason may be that it doesn’t find ‘fairymax’ (what’s
that?) in $PATH.  I’m sure I’m missing something obvious, but I wonder
if we could make it work out of the box.

Thoughts?

Ludo’.
Michael Rohleder May 3, 2021, 4:13 p.m. UTC | #2
Hi Ludo,

Thank you for reviewing!

Ludovic Courtès <ludo@gnu.org> writes:
> Incidentally, the following still breaks on the first move:
>
>   $ guix environment --ad-hoc xboard -- xboard
>   […]
>   xboard: Error writing to first chess program: Broken pipe
>
> At first sight the reason may be that it doesn’t find ‘fairymax’ (what’s
> that?) in $PATH.  I’m sure I’m missing something obvious, but I wonder
> if we could make it work out of the box.
>
> Thoughts?
>

Yes, I think that is https://issues.guix.gnu.org/45236

fairymax is a (simple) chessengine.

I plan to fix this issue (also via the xboard.conf), so that gnuchess
gets the default configured engine, after this one here is merged...
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..8bd3c95ebb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3323,8 +3323,19 @@  exec ~a/bin/freedink -refdir ~a/share/dink\n"
         (base32
          "1mkh36xnnacnz9r00b5f9ld9309k32jv6mcavklbdnca8bl56bib"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Fixes https://issues.guix.gnu.org/47195.
+         (add-after 'unpack 'patch-aplay-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "xboard.conf"
+               (("aplay -q")
+                (string-append (assoc-ref inputs "alsa-utils") "/bin/aplay -q")))
+             #t)))))
     (inputs
-     `(("gtk+" ,gtk+-2)
+     `(("alsa-utils" ,alsa-utils)
+       ("gtk+" ,gtk+-2)
        ("librsvg" ,librsvg)))
     (native-inputs
      `(("texinfo" ,texinfo)