diff mbox series

[bug#48091,v7,03/10] gnu: Add python-pytest-click.

Message ID 20210501172126.28033-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48091,v7,01/10] gnu: Add python-colorful. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan May 1, 2021, 5:21 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-click): New variable.
---
 gnu/packages/python-check.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b68f23a220..01922b0d9d 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -46,6 +46,27 @@ 
   #:use-module (guix download)
   #:use-module (guix build-system python))
 
+(define-public python-pytest-click
+  (package
+    (name "python-pytest-click")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (pypi-uri "pytest_click" version))
+       (sha256
+        (base32 "1rcv4m850rl7djzdgzz2zhjd8g5ih8w6l0sj2f9hsynymlsq82xl"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-click" ,python-click)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/Stranger6667/pytest-click")
+    (synopsis "Py.test plugin for Click")
+    (description "This package provides a plugin to test Python click
+interfaces with pytest.")
+    (license license:expat)))
+
 (define-public python-testfixtures
   (package
     (name "python-testfixtures")