diff mbox series

[bug#48130] gnu: chessx: Disable online version check by default.

Message ID 20210430232900.30324-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#48130] gnu: chessx: Disable online version check by default. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder April 30, 2021, 11:29 p.m. UTC
* gnu/packages/games.scm (chessx)[arguments]: Add phase to disable
the online version check by default.
---
 gnu/packages/games.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Ludovic Courtès May 3, 2021, 4:08 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/games.scm (chessx)[arguments]: Add phase to disable
> the online version check by default.

Applied, thanks!

Good that you found about this antifeature.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e6fc..4b0f9d74e0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11885,6 +11885,12 @@  and chess engines.")
            (lambda _
              (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
              #t))
+         (add-after 'make-qt-deterministic 'disable-versioncheck
+           (lambda _
+             (substitute* "src/database/settings.cpp"
+               (("\"/General/onlineVersionCheck\", true")
+                "\"/General/onlineVersionCheck\", false"))
+             #t))
          (replace 'configure
            (lambda _
              (invoke "qmake")