diff mbox series

[bug#48112] gnu: neovim: Add 'XDG_DATA_DIRS' search path spec.

Message ID 20210430043919.17536-1-jackhill@jackhill.us
State New
Headers show
Series [bug#48112] gnu: neovim: Add 'XDG_DATA_DIRS' search path spec. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill April 30, 2021, 4:39 a.m. UTC
* gnu/packages/vim.scm (neovim)[native-search-paths]: New field.
---
 gnu/packages/vim.scm | 8 ++++++++
 1 file changed, 8 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5d2beb531b..453a13eabe 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -676,6 +676,14 @@  are detected, the user is notified.")))
              (substitute* "cmake/GetCompileFlags.cmake"
                (("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
              #t)))))
+    (native-search-paths
+     ;; Neovim searches the nvim/site subdirectory of each XDG_DATA_DIRS entry
+     ;; for plugins and other addons.  In nvim see `:help runtimepath`
+     ;; https://neovim.io/doc/user/options.html#'runtimepath'
+     (list (search-path-specification
+            (variable "XDG_DATA_DIRS")
+            (separator ":")
+            (files '("share")))))
     (inputs
      `(("libuv" ,libuv)
        ("msgpack" ,msgpack)