diff mbox series

[bug#48076] gnu: odamex: Update to 0.9.0.

Message ID 20210428030630.1503268-1-david@pflug.io
State Accepted
Headers show
Series [bug#48076] gnu: odamex: Update to 0.9.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

David Pflug April 28, 2021, 3:06 a.m. UTC
* gnu/packages/games.scm (odamex): Update to 0.9.0.
---
 gnu/packages/games.scm | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès May 3, 2021, 4:19 p.m. UTC | #1
Hi David,

David Pflug <david@pflug.io> skribis:

> * gnu/packages/games.scm (odamex): Update to 0.9.0.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3227b3e..378ea9a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -59,6 +59,7 @@ 
 ;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2021 David Pflug <david@pflug.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7472,22 +7473,25 @@  Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
 (define-public odamex
   (package
     (name "odamex")
-    (version "0.8.3")
+    (version "0.9.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "mirror://sourceforge/odamex/Odamex/" version "/"
-             "odamex-src-" version ".tar.gz"))
+             "odamex-src-" version ".tar.bz2"))
        (sha256
-        (base32 "0f887g87bmcq4dpcga7xc2mpxs947dkbc934ir9xs55gz6z13q96"))))
+        (base32 "0yfrvx8zb3chy47fyz4nik6gbh0y5608yvld4gz4y8l158qk71y1"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f))          ; no tests
+    (native-inputs
+     `(("deutex" ,deutex)))
     (inputs
-     `(("sdl" ,sdl)
-       ("sdl-mixer" ,sdl-mixer)
+     `(("sdl" ,sdl2)
+       ("sdl-mixer" ,sdl2-mixer)
        ("zlib" ,zlib)
        ("libpng" ,libpng)
+       ("curl" ,curl-minimal)
        ("alsa-lib" ,alsa-lib)))
     (home-page "https://odamex.net/")
     (synopsis "Multiplayer Doom port")