diff mbox series

[bug#48048] update blender to 2.92

Message ID 20210426170506.3f99aa1c@riseup.net
State Accepted
Headers show
Series [bug#48048] update blender to 2.92 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp April 26, 2021, 3:05 p.m. UTC
Tiny update for Blender. Tested with some quick geometry nodes
shenanigans, everything seems to be in order.
Piled another explicit path definition onto the pile to fix the build.
Sadly it doesn't fail during configure without it, only a good half way
into the build does it error. Some brave soul should probably fix that
upstream and then we could get rid of all that added complexity.

Comments

Leo Famulari May 3, 2021, 5:06 p.m. UTC | #1
On Mon, Apr 26, 2021 at 05:05:06PM +0200, raingloom wrote:
> Tiny update for Blender. Tested with some quick geometry nodes
> shenanigans, everything seems to be in order.
> Piled another explicit path definition onto the pile to fix the build.
> Sadly it doesn't fail during configure without it, only a good half way
> into the build does it error. Some brave soul should probably fix that
> upstream and then we could get rid of all that added complexity.

> From 2e4c63de33641b015606b4cc63f908286e55954b Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Mon, 26 Apr 2021 16:58:47 +0200
> Subject: [PATCH] gnu: blender: Update to 2.92.0.
> 
> * gnu/packages/graphics.scm (blender): Update to 2.92.0.
>   [arguments]: Added workaround for numpy headers not being found.

Thanks! I pushed as 9ffa81fe64ee405e1a861b72a21bca966fcbc236 after
fixing the commit message to describe the changes more explicitly.
diff mbox series

Patch

From 2e4c63de33641b015606b4cc63f908286e55954b Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Mon, 26 Apr 2021 16:58:47 +0200
Subject: [PATCH] gnu: blender: Update to 2.92.0.

* gnu/packages/graphics.scm (blender): Update to 2.92.0.
  [arguments]: Added workaround for numpy headers not being found.
---
 gnu/packages/graphics.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7e83c7ea4e..da4b5ae32c 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -466,14 +466,14 @@  applications.")
 (define-public blender
   (package
     (name "blender")
-    (version "2.91.0")
+    (version "2.92.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.blender.org/source/"
                                   "blender-" version ".tar.xz"))
               (sha256
                (base32
-                "0x396lgmk0dq9115yrc36s8zwxzmjr490sr5n2y6w27y17yllyjm"))))
+                "15a5vffn18a920286x0avbc2rap56k6y531wgibq68r90g2cz4g7"))))
     (build-system cmake-build-system)
     (arguments
       (let ((python-version (version-major+minor (package-version python))))
@@ -498,6 +498,9 @@  applications.")
                (string-append "-DPYTHON_INCLUDE_DIR=" (assoc-ref %build-inputs "python")
                               "/include/python" ,python-version)
                (string-append "-DPYTHON_VERSION=" ,python-version)
+               (string-append "-DPYTHON_NUMPY_INCLUDE_DIRS="
+                              (assoc-ref %build-inputs "python-numpy")
+                              "/lib/python" ,python-version "/site-packages/numpy/core/include/")
                (string-append "-DPYTHON_NUMPY_PATH="
                               (assoc-ref %build-inputs "python-numpy")
                               "/lib/python" ,python-version "/site-packages/"))
-- 
2.31.1