diff mbox series

[bug#48028,wip-gnome,v3,03/10] gnu: gtkmm: Add missing native-input and correct propagated-inputs.

Message ID 20210426092215.31032-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48028,wip-gnome,v3,01/10] gnu: gtkmm@2: Remove inheritance from gtkmm@3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 26, 2021, 9:22 a.m. UTC
* gnu/packages/gtk.scm (gtkmm)[native-inputs]: Add glib:bin.
[propagated-inputs]: Change; atkmm to atkmm-2.28, pangomm to pangomm-2.42,
and cairomm to cairomm-1.13.
---
 gnu/packages/gtk.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a7e387a47d..86490115d6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1633,6 +1633,7 @@  library.")
     (native-inputs
      `(("dot" ,graphviz)
        ("doxygen" ,doxygen)
+       ("glib:bin" ,glib "bin") ; For glib-compile-resources
        ("m4" ,m4)
        ("mm-common" ,mm-common)
        ("perl" ,perl)
@@ -1640,11 +1641,11 @@  library.")
        ("xsltproc" ,libxslt)
        ("xorg-server" ,xorg-server-for-tests)))
     (propagated-inputs
-     `(("atkmm" ,atkmm)
-       ("cairomm" ,cairomm)
+     `(("atkmm" ,atkmm-2.28)
+       ("cairomm" ,cairomm-1.13)
        ("glibmm" ,glibmm)
        ("gtk+" ,gtk+)
-       ("pangomm" ,pangomm)))
+       ("pangomm" ,pangomm-2.42)))
     (synopsis "C++ Interfaces for GTK+ and GNOME")
     (description "GTKmm is the official C++ interface for the popular GUI
 library GTK+.  Highlights include typesafe callbacks, and a comprehensive set of