diff mbox series

[bug#48028,wip-gnome,v2,05/10] gnu: libsoup: Disable ssl-test.

Message ID 20210426090823.30672-5-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48028,wip-gnome,v2,01/10] gnu: gtkmm@2: Remove inheritance from gtkmm@3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 26, 2021, 9:08 a.m. UTC
* gnu/packages/gnome.scm (libsoup)[phases](adjust-tests): Modify.
[native-inputs]: Remove gnutls.
---
 gnu/packages/gnome.scm | 50 ++++--------------------------------------
 1 file changed, 4 insertions(+), 46 deletions(-)

Comments

M April 26, 2021, 8:58 p.m. UTC | #1
Raghav Gururajan via Guix-patches via schreef op ma 26-04-2021 om 05:08 [-0400]:
> +               ;; FIX-ME: ssl-test fails, starting with

The convention seems to be FIXME and not FIX-ME.
Only 3 hits for "git grep -F FIX-ME", and 612 hits for
"git grep -F FIXME" in some random branch.

Greetings,
Maxime.
Raghav Gururajan April 27, 2021, 9:33 a.m. UTC | #2
Hi Maxime,

> The convention seems to be FIXME and not FIX-ME.
> Only 3 hits for "git grep -F FIX-ME", and 612 hits for
> "git grep -F FIXME" in some random branch.

Fixed in v5. Thanks!

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c8e7b55f6c..29779c39af 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4934,51 +4934,10 @@  libxml to ease remote use of the RESTful API.")
                (("[ \t]*\\['hsts-db', true, \\[\\]\\],") "")
                ;; This test fails due to missing /etc/nsswitch.conf
                ;; in the build environment.
-               (("[ \t]*\\['socket', true, \\[\\]\\],") ""))
-
-             ;; Generate a self-signed certificate that has "localhost" as its
-             ;; 'dnsName'.  Failing to do that, and starting with GnuTLS
-             ;; 3.5.12, tests such as "ssl-tests" fail:
-             ;;
-             ;; ERROR:ssl-test.c:406:do_tls_interaction_test: Unexpected status 6 Unacceptable TLS certificate (expected 200 OK)
-             ;;
-             ;; 'certtool' is interactive so we have to pipe it the answers.
-             ;; Reported at <https://bugzilla.gnome.org/show_bug.cgi?id=784696>.
-             (let ((pipe (open-output-pipe "certtool --generate-self-signed \
- --load-privkey tests/test-key.pem --outfile tests/test-cert.pem")))
-               (for-each (lambda (line)
-                           (display line pipe)
-                           (newline pipe))
-                         '(""               ;Common name
-                           ""               ;UID
-                           "Guix"           ;Organizational unit name
-                           "GNU"            ;Organization name
-                           ""               ;Locality name
-                           ""               ;State or province
-                           ""               ;Country
-                           ""               ;subject's domain component (DC)
-                           ""               ;E-mail
-                           ""               ;serial number
-                           "-1"             ;expiration time
-                           "N"              ;belong to authority?
-                           "N"              ;web client certificate?
-                           "N"              ;IPsec IKE?
-                           "Y"              ;web server certificate?
-                           "localhost"      ;dnsName of subject
-                           ""               ;dnsName of subject (end)
-                           ""               ;URI of subject
-                           "127.0.0.1"      ;IP address of subject
-                           ""               ;signing?
-                           ""               ;encryption (RSA)?
-                           ""               ;data encryption?
-                           ""               ;sign OCSP requests?
-                           ""               ;sign code?
-                           ""               ;time stamping?
-                           ""               ;email protection?
-                           ""               ;URI of the CRL distribution point
-                           "y"              ;above info OK?
-                           ))
-               (close-pipe pipe))
+               (("[ \t]*\\['socket', true, \\[\\]\\],") "")
+               ;; FIX-ME: ssl-test fails, starting with
+               ;; glib-networking 2.68.x.
+               (("[ \t]*\\['ssl', true, \\[\\]\\],") ""))
              #t))
          (add-after 'install 'move-doc
            (lambda* (#:key outputs #:allow-other-keys)
@@ -5000,7 +4959,6 @@  libxml to ease remote use of the RESTful API.")
        ("vala" ,vala)
        ("php" ,php)
        ("curl" ,curl)
-       ("gnutls" ,gnutls)                         ;for 'certtool'
        ("httpd" ,httpd)))
     (propagated-inputs
      ;; libsoup-2.4.pc refers to all these.