diff mbox series

[bug#48028,wip-gnome,v2,04/10] gnu: libsoup: Simplify adjustment of tests.

Message ID 20210426090823.30672-4-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48028,wip-gnome,v2,01/10] gnu: gtkmm@2: Remove inheritance from gtkmm@3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 26, 2021, 9:08 a.m. UTC
Switch from using mutiple C files to single meson.build file.

* gnu/packages/gnome.scm (libsoup)[phases](adjust-tests): Modify.
---
 gnu/packages/gnome.scm | 22 ++++++++--------------
 1 file changed, 8 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 97cf80c586..c8e7b55f6c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4927,20 +4927,14 @@  libxml to ease remote use of the RESTful API.")
                #t)))
          (add-after 'unpack 'adjust-tests
            (lambda _
-             ;; This test fails due to missing /etc/nsswitch.conf
-             ;; in the build environment.
-             (substitute* "tests/socket-test.c"
-               ((".*/sockets/unconnected.*") ""))
-
-             ;; These fail because "subdomain.localhost" does not resolve in
-             ;; the build environment.
-             (substitute* "tests/hsts-test.c"
-               ((".*/hsts/basic.*") "")
-               ((".*/hsts/subdomains.*") "")
-               ((".*/hsts/superdomain.*") "")
-               ((".*/hsts/utf8-address.*") ""))
-             (substitute* "tests/hsts-db-test.c"
-               ((".*/hsts-db/subdomains.*") ""))
+             (substitute* "tests/meson.build"
+               ;; These fail because "subdomain.localhost" does not resolve in
+               ;; the build environment.
+               (("[ \t]*\\['hsts', true, \\[\\]\\],") "")
+               (("[ \t]*\\['hsts-db', true, \\[\\]\\],") "")
+               ;; This test fails due to missing /etc/nsswitch.conf
+               ;; in the build environment.
+               (("[ \t]*\\['socket', true, \\[\\]\\],") ""))
 
              ;; Generate a self-signed certificate that has "localhost" as its
              ;; 'dnsName'.  Failing to do that, and starting with GnuTLS