diff mbox series

[bug#48028,wip-gnome,3/8] gnu: gtkmm: Add missing native-input and correct propagated-inputs.

Message ID 20210426081145.28926-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#48028,wip-gnome,1/8] gnu: gtkmm@2: Remove inheritance from gtkmm@3. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 26, 2021, 8:11 a.m. UTC
* gnu/packages/gtk.scm (gtkmm)[native-inputs]: Add glib:bin.
[propagated-inputs]: Change; atkmm to atkmm-2.28, pangomm to pangomm-2.42,
and cairomm to cairomm-1.13.
---
 gnu/packages/gtk.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

M April 26, 2021, 8:52 p.m. UTC | #1
Raghav Gururajan via Guix-patches via schreef op ma 26-04-2021 om 04:11 [-0400]:
> * gnu/packages/gtk.scm (gtkmm)[native-inputs]: Add glib:bin.

Maybe make this "Add glib:lib for glib-compile-resources" for clarity.
> [propagated-inputs]: Change; atkmm to atkmm-2.28, pangomm to pangomm-2.42,
> and cairomm to cairomm-1.13.
See comment below.

> ---
>  gnu/packages/gtk.scm | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index a7e387a47d..86490115d6 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1633,6 +1633,7 @@ library.")
>      (native-inputs
>       `(("dot" ,graphviz)
>         ("doxygen" ,doxygen)
> +       ("glib:bin" ,glib "bin") ; For glib-compile-resources
LGTM

>         ("m4" ,m4)
>         ("mm-common" ,mm-common)
>         ("perl" ,perl)
> @@ -1640,11 +1641,11 @@ library.")
>         ("xsltproc" ,libxslt)
>         ("xorg-server" ,xorg-server-for-tests)))
>      (propagated-inputs
> -     `(("atkmm" ,atkmm)
> -       ("cairomm" ,cairomm)
> +     `(("atkmm" ,atkmm-2.28)
> +       ("cairomm" ,cairomm-1.13)
>         ("glibmm" ,glibmm)
>         ("gtk+" ,gtk+)
> -       ("pangomm" ,pangomm)))
> +       ("pangomm" ,pangomm-2.42)))

What makes the old propageted-inputs incorrect, and the new ones correct?
Has there been an ABI change or something, or does GTKmm now require new
APIs?  Could you add a little comment why the old inputs were incorrect
in the commit message?

Greetings,
Maxime.
Raghav Gururajan April 27, 2021, 9:32 a.m. UTC | #2
Hi Maxime,

> Maybe make this "Add glib:lib for glib-compile-resources" for clarity.

But that wouldn't involve other changes.

> What makes the old propageted-inputs incorrect, and the new ones correct?
> Has there been an ABI change or something, or does GTKmm now require new
> APIs?  Could you add a little comment why the old inputs were incorrect
> in the commit message?

It's ABI incompatibility. I have added comment in the code, in v5.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a7e387a47d..86490115d6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1633,6 +1633,7 @@  library.")
     (native-inputs
      `(("dot" ,graphviz)
        ("doxygen" ,doxygen)
+       ("glib:bin" ,glib "bin") ; For glib-compile-resources
        ("m4" ,m4)
        ("mm-common" ,mm-common)
        ("perl" ,perl)
@@ -1640,11 +1641,11 @@  library.")
        ("xsltproc" ,libxslt)
        ("xorg-server" ,xorg-server-for-tests)))
     (propagated-inputs
-     `(("atkmm" ,atkmm)
-       ("cairomm" ,cairomm)
+     `(("atkmm" ,atkmm-2.28)
+       ("cairomm" ,cairomm-1.13)
        ("glibmm" ,glibmm)
        ("gtk+" ,gtk+)
-       ("pangomm" ,pangomm)))
+       ("pangomm" ,pangomm-2.42)))
     (synopsis "C++ Interfaces for GTK+ and GNOME")
     (description "GTKmm is the official C++ interface for the popular GUI
 library GTK+.  Highlights include typesafe callbacks, and a comprehensive set of