diff mbox series

[bug#48020,3/4] gnu: mlt: Add optional dependencies.

Message ID 20210425181724.167792-2-monego@posteo.net
State Accepted
Headers show
Series [bug#48020,1/4] gnu: mlt: Update license. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego April 25, 2021, 6:17 p.m. UTC
* gnu/packages/video.scm (mlt)[inputs]: Add alsa-plugins:pulseaudio,
libebur128, rtaudio, sdl2, sdl2-image, sox, vidstab. Remove sdl.
---
alsa-plugins is required for Shotcut.

 gnu/packages/video.scm | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index c86c681cdd..e0d5e30a13 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2984,6 +2984,7 @@  from sites like Twitch.tv and pipes them into a video player of choice.")
              #t)))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
+       ("alsa-plugins" ,alsa-plugins "pulseaudio")
        ("ffmpeg" ,ffmpeg)
        ("fftw" ,fftw)
        ("frei0r-plugins" ,frei0r-plugins)
@@ -2992,6 +2993,7 @@  from sites like Twitch.tv and pipes them into a video player of choice.")
        ("libxml2" ,libxml2)
        ("jack" ,jack-1)
        ("ladspa" ,ladspa)
+       ("libebur128" ,libebur128)
        ("libexif" ,libexif)
        ("libvorbis" ,libvorbis)
        ("rubberband" ,rubberband)
@@ -2999,8 +3001,11 @@  from sites like Twitch.tv and pipes them into a video player of choice.")
        ("pulseaudio" ,pulseaudio)
        ("qtbase" ,qtbase)
        ("qtsvg" ,qtsvg)
-       ("sdl" ,sdl)
-       ("sox" ,sox)))
+       ("rtaudio" ,rtaudio)
+       ("sdl2" ,sdl2)
+       ("sdl2-image" ,sdl2-image)
+       ("sox" ,sox)
+       ("vidstab" ,vidstab)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (home-page "https://www.mltframework.org/")