diff mbox series

[bug#47997,1/2] gnu: Add nyan.

Message ID 20210424163926.22301-1-arunisaac@systemreboot.net
State New
Headers show
Series Add openage | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac April 24, 2021, 4:39 p.m. UTC
* gnu/packages/games.scm (nyan): New variable.
---
 gnu/packages/games.scm | 33 ++++++++++++++++++++++++++++++++-
 1 file changed, 32 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5b316f1997..4d565395ee 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -23,7 +23,7 @@ 
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
 ;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
-;;; Copyright © 2017, 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2019 nee <nee-git@hidamari.blue>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
@@ -12419,3 +12419,34 @@  game FPS.")
 implemented using ncurses user interface.  An SDL graphical version is also
 available.")
     (license license:gpl3+)))
+
+(define-public nyan
+  (package
+    (name "nyan")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/SFTtech/nyan")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1jx874hmj7102ir4z95np5dgmavnh5dgj5iyz0ga8h4wa82n58dv"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "./nyan/nyancat" "--test-parser"
+                     "-f" "../source/test/test.nyan"))))))
+    (native-inputs
+     `(("flex" ,flex)))
+    (home-page "https://github.com/SFTtech/nyan")
+    (synopsis "Data description language for openage")
+    (description "nyan is a data description language.  It stores hierarchical
+objects with key-value pairs in a database with the key idea that changes in a
+parent affect all children.  The main focus is readability and moddability.")
+    (license license:lgpl3+)))