diff mbox series

[bug#47914] gnu: Add daemonize.

Message ID 20210420182345.29735-1-winterhound@yandex.com
State Accepted
Headers show
Series [bug#47914] gnu: Add daemonize. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

WinterHound April 20, 2021, 6:23 p.m. UTC
---
 gnu/packages/xdisorg.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Nicolò Balzarotti April 20, 2021, 6:42 p.m. UTC | #1
Hi!

WinterHound <winterhound@yandex.com> writes:

> +(define-public xdo

The patch name (daemonize) seems not to match the defined package.

License seems ok and tests are missing.

guix lint does not complain

Package builds fine and output binary does work.

There's a typo in the description (optioqqns -> options).  Also, the
second part of the description seems to be too specific, but others
might have a different opinion.

Thanks, Nicolò
Ludovic Courtès May 22, 2021, 9:51 p.m. UTC | #2
Hi,

Nicolò Balzarotti <anothersms@gmail.com> skribis:

> WinterHound <winterhound@yandex.com> writes:
>
>> +(define-public xdo
>
> The patch name (daemonize) seems not to match the defined package.
>
> License seems ok and tests are missing.
>
> guix lint does not complain
>
> Package builds fine and output binary does work.
>
> There's a typo in the description (optioqqns -> options).  Also, the
> second part of the description seems to be too specific, but others
> might have a different opinion.

I fixed these issues and applied it.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 725ea0afd6..37f88f2766 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -510,6 +510,39 @@  manager supports it, you can use xdotool to switch desktops, move windows
 between desktops, and change the number of desktops.")
     (license license:bsd-3)))
 
+(define-public xdo
+  (package
+    (name "xdo")
+    (version "0.5.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/baskerville/xdo")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1h3jrygcjjbavdbkpx2hscsf0yf97gk487lzjdlvymd7dxdv9hy9"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs
+     `(("libxcb" ,libxcb)
+       ("xcb-util-wm" ,xcb-util-wm)
+       ("xcb-util" ,xcb-util)))
+    (home-page "https://github.com/baskerville/xdo")
+    (synopsis "Small X utility to perform elementary actions on windows")
+    (description
+     "Apply the given action to the given windows.
+If no window IDs and no optioqqns are given, the action applies to the focused window.")
+    (license license:bsd-2)))
+
 (define-public xeyes
   (package
     (name "xeyes")