diff mbox series

[bug#47730,4/4] gnu: Add watson.

Message ID 20210415135757.16173-1-mail@sebastiangibb.de
State New
Headers show
Series None | expand

Commit Message

Sebastian Gibb April 15, 2021, 1:57 p.m. UTC
* gnu/packages/time.scm (watson): New variable.
---
Dear Maxime,

thanks for your review.

I removed the #t and the newline in the snyopsis as you suggested.

 gnu/packages/time.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index dfade604a3..ab9e66285f 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -41,6 +41,8 @@ 
   #:use-module (gnu packages golang)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages terminals)
   #:use-module (gnu packages textutils)
@@ -540,3 +542,40 @@  calls.")
 from a starting point you provide.  The user can pause and resume the
 countdown from the text user interface.")
     (license expat)))
+
+(define-public watson
+  (package
+    (name "watson")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tailordev/watson")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1yxqjirv7cpg4hqj4l3a53p3p3kl82bcx6drgvl9v849vcc3l7s0"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "pytest"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-datafiles" ,python-pytest-datafiles)
+       ("python-pytest-mock" ,python-pytest-mock)))
+    (inputs
+     `(("python-arrow" ,python-arrow)
+       ("python-click" ,python-click)
+       ("python-click-didyoumean" ,python-click-didyoumean)
+       ("python-colorama" ,python-colorama)
+       ("python-requests" ,python-requests)))
+    (home-page "https://tailordev.github.io/Watson/")
+    (synopsis "Command-line time tracker")
+    (description
+     "Watson is command-line interface to manage your time.  It supports
+     projects, tagging and reports.")
+    (license expat)))