diff mbox series

[bug#47779] gnu: oil: Update to 0.8.9.

Message ID 20210414171639.5571-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#47779] gnu: oil: Update to 0.8.9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber April 14, 2021, 5:16 p.m. UTC
* gnu/packages/shells.scm (oil): Update to 0.8.9.
  [arguments]: Fix warning about `check` phase not returning #f.
---
 gnu/packages/shells.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Leo Famulari April 14, 2021, 5:49 p.m. UTC | #1
On Wed, Apr 14, 2021 at 07:16:39PM +0200, Felix Gruber wrote:
> * gnu/packages/shells.scm (oil): Update to 0.8.9.
>   [arguments]: Fix warning about `check` phase not returning #f.

Thanks! Pushed as dd9e77f81bce7fd3c869ee68b7ce68153d934460
Tobias Geerinckx-Rice April 14, 2021, 6 p.m. UTC | #2
Felix,

> * gnu/packages/shells.scm (oil): Update to 0.8.9.

Thanks!  I tried to push it but no luck.

> [arguments]: Fix warning about `check` phase not returning #f.

Ignore this warning next time.  It's obsolete, but can only be 
removed on the next core-updates merge (when we can start removing 
all these silly #Ts again).

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5ab3642dea..f2356dbdb4 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -825,14 +825,14 @@  Shell (pdksh).")
 (define-public oil
   (package
     (name "oil")
-    (version "0.8.8")
+    (version "0.8.9")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.oilshell.org/download/oil-"
                            version ".tar.gz"))
        (sha256
-        (base32 "1g3xk160x9k5smfc9k8nnxcj7w1nacmnhnpmm72am9rjp1vpv9h1"))))
+        (base32 "080lsx7hyjhny3jzscwr152vr0g9s3c2iqg3vrpgsbk8vv7vw5l7"))))
     (build-system gnu-build-system)
     (arguments
      `(#:strip-binaries? #f             ; strip breaks the binary
@@ -853,7 +853,8 @@  Shell (pdksh).")
            (lambda _
              (let* ((oil "_bin/oil.ovm"))
                (invoke/quiet oil "osh" "-c" "echo hi")
-               (invoke/quiet oil "osh" "-n" "configure")))))))
+               (invoke/quiet oil "osh" "-n" "configure")
+               #t))))))
     (inputs
      `(("readline" ,readline)))
     (home-page "https://www.oilshell.org")