diff mbox series

[bug#47770,core-updates,2/4] gnu: ibus: Enable documentation.

Message ID 20210414115349.14040-2-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#47770,core-updates,1/4] gnu: ibus: Update to 1.5.24. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 14, 2021, 11:53 a.m. UTC
* gnu/packages/ibus.scm (ibus)[outputs](doc): New output.
[configure-flags](enable-gtk-doc): New flag.
[phases](patch-docbook-xml): New phase.
(move-doc): New phase.
[native-inputs]: Add docbook-xml and gtk-doc.
---
 gnu/packages/ibus.scm | 24 +++++++++++++++++++++++-
 1 file changed, 23 insertions(+), 1 deletion(-)

Comments

M April 14, 2021, 9:21 p.m. UTC | #1
On Wed, 2021-04-14 at 07:53 -0400, Raghav Gururajan via Guix-patches via wrote:
>         #:phases
>         (modify-phases %standard-phases
> +         (add-after 'unpack 'patch-docbook-xml
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (with-directory-excursion "docs/reference/ibus"
> +               (substitute* "ibus-docs.sgml.in"
> +                 (("http://www.oasis-open.org/docbook/xml/4.1.2/")
> +                  (string-append (assoc-ref inputs "docbook-xml")
> +                                 "/xml/dtd/docbook/"))))
> +              #t))

Letting a phase return #t isn't required anymore, and the warning has
been removed on core-updates (which this patch series is targetting.
The #t can be dropped now.

>           (add-after 'unpack 'patch-python-target-directories
>             (lambda* (#:key outputs #:allow-other-keys)
>               (let ((root (string-append (assoc-ref outputs "out")
> @@ -127,6 +138,15 @@
>                 (("\"(setxkbmap|xmodmap)\"" _ prog)
>                  (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
>               #t))

While you're modifying the package anyway, you might as well drop this one too.
> +         (add-after 'install 'move-doc
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (let* ((out (assoc-ref outputs "out"))
> +                    (doc (assoc-ref outputs "doc")))
> +               (mkdir-p (string-append doc "/share"))
> +               (rename-file
> +                (string-append out "/share/gtk-doc")
> +                (string-append doc "/share/gtk-doc"))
> +               #t)))
Likewise.

Warning: I didn't test this patch series.

Greetings,
Maxime.
Raghav Gururajan April 15, 2021, 12:31 p.m. UTC | #2
Hi Maxime!

> On Wed, 2021-04-14 at 07:53 -0400, Raghav Gururajan via Guix-patches via wrote:
>>          #:phases
>>          (modify-phases %standard-phases
>> +         (add-after 'unpack 'patch-docbook-xml
>> +           (lambda* (#:key inputs #:allow-other-keys)
>> +             (with-directory-excursion "docs/reference/ibus"
>> +               (substitute* "ibus-docs.sgml.in"
>> +                 (("http://www.oasis-open.org/docbook/xml/4.1.2/")
>> +                  (string-append (assoc-ref inputs "docbook-xml")
>> +                                 "/xml/dtd/docbook/"))))
>> +              #t))
> 
> Letting a phase return #t isn't required anymore, and the warning has
> been removed on core-updates (which this patch series is targetting.
> The #t can be dropped now.
> 
>>            (add-after 'unpack 'patch-python-target-directories
>>              (lambda* (#:key outputs #:allow-other-keys)
>>                (let ((root (string-append (assoc-ref outputs "out")
>> @@ -127,6 +138,15 @@
>>                  (("\"(setxkbmap|xmodmap)\"" _ prog)
>>                   (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
>>                #t))
> 
> While you're modifying the package anyway, you might as well drop this one too.
>> +         (add-after 'install 'move-doc
>> +           (lambda* (#:key outputs #:allow-other-keys)
>> +             (let* ((out (assoc-ref outputs "out"))
>> +                    (doc (assoc-ref outputs "doc")))
>> +               (mkdir-p (string-append doc "/share"))
>> +               (rename-file
>> +                (string-append out "/share/gtk-doc")
>> +                (string-append doc "/share/gtk-doc"))
>> +               #t)))
> Likewise.

I have removed #t in v2.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index e566993b08..b6687239df 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -42,6 +42,7 @@ 
   #:use-module (gnu packages databases)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages docbook)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -73,10 +74,12 @@ 
                (base32
                 "07s2ly75xv50bqg37mn37i9akqvcfd45k2mbplxrsqk3a2b3mwxb"))))
     (build-system glib-or-gtk-build-system)
+    (outputs '("out" "doc"))
     (arguments
      `(#:tests? #f  ; tests fail because there's no connection to dbus
        #:parallel-build? #f ; race condition discovered with emoji support
        #:configure-flags (list "--enable-python-library"
+                               "--enable-gtk-doc"
                                (string-append
                                 "--with-unicode-emoji-dir="
                                 (assoc-ref %build-inputs "unicode-emoji")
@@ -91,6 +94,14 @@ 
                                "--enable-wayland")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-docbook-xml
+           (lambda* (#:key inputs #:allow-other-keys)
+             (with-directory-excursion "docs/reference/ibus"
+               (substitute* "ibus-docs.sgml.in"
+                 (("http://www.oasis-open.org/docbook/xml/4.1.2/")
+                  (string-append (assoc-ref inputs "docbook-xml")
+                                 "/xml/dtd/docbook/"))))
+              #t))
          (add-after 'unpack 'patch-python-target-directories
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((root (string-append (assoc-ref outputs "out")
@@ -127,6 +138,15 @@ 
                (("\"(setxkbmap|xmodmap)\"" _ prog)
                 (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
              #t))
+         (add-after 'install 'move-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share"))
+               (rename-file
+                (string-append out "/share/gtk-doc")
+                (string-append doc "/share/gtk-doc"))
+               #t)))
          (add-after 'wrap-program 'wrap-with-additional-paths
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Make sure 'ibus-setup' runs with the correct PYTHONPATH and
@@ -160,10 +180,12 @@ 
        ("wayland" ,wayland)
        ("xmodmap" ,xmodmap)))
     (native-inputs
-     `(("glib" ,glib "bin")             ; for glib-genmarshal
+     `(("docbook-xml" ,docbook-xml-4.1.2)
+       ("glib" ,glib "bin")             ; for glib-genmarshal
        ("gettext" ,gettext-minimal)
        ("gnome-common" ,gnome-common)
        ("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
+       ("gtk-doc" ,gtk-doc)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)