diff mbox series

[bug#47768,07/37] gnu: Add ocaml-gen.

Message ID 20210414091303.6990-7-pukkamustard@posteo.net
State Accepted
Headers show
Series Assorted OCaml patches | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard April 14, 2021, 9:12 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-gen): New variable.
  (ocaml4.07-gen): Remove variable.
  (ocaml4.07-sedlex): Replace ocaml4.07-gen with ocaml-gen.
---
 gnu/packages/ocaml.scm | 17 +++++++----------
 1 file changed, 7 insertions(+), 10 deletions(-)

Comments

M April 14, 2021, 6:54 p.m. UTC | #1
> -(define-public ocaml4.07-gen
> +(define-public ocaml-gen
>    [...]
>     `(#:tests? #f; no tests
> -       #:package "gen"
> -       #:ocaml ,ocaml-4.07
> -       #:findlib ,ocaml4.07-findlib
> -       #:dune ,ocaml4.07-dune))
> +       #:package "gen"))
>      (propagated-inputs
> -     `(("ocaml-odoc" ,(package-with-ocaml4.07 ocaml4.07-odoc))))
> +     `(("ocaml-odoc" ,ocaml-odoc)))
>      (native-inputs
> -     `(("ocaml-qtest" ,(package-with-ocaml4.07 ocaml-qtest))
> -       ("ocaml-qcheck" ,(package-with-ocaml4.07 ocaml-qcheck))))
> +     `(("ocaml-qtest" ,ocaml-qtest)
> +       ("ocaml-qcheck" ,ocaml-qcheck)))

I'm confused what's going on here.
ocaml-qtest is for unit tests (https://opam.ocaml.org/packages/qtest/qtest.2.1.0/),
but for this package we have ‘#:tests? #f; no tests?’?
That seems contradictory.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 503913c8fd..43a3bc1d40 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2508,9 +2508,9 @@  format.  It can process XML documents without a complete in-memory
 representation of the data.")
     (license license:isc)))
 
-(define-public ocaml4.07-gen
+(define-public ocaml-gen
   (package
-    (name "ocaml4.07-gen")
+    (name "ocaml-gen")
     (version "0.5.3")
     (source (origin
               (method git-fetch)
@@ -2524,15 +2524,12 @@  representation of the data.")
     (build-system dune-build-system)
     (arguments
      `(#:tests? #f; no tests
-       #:package "gen"
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib
-       #:dune ,ocaml4.07-dune))
+       #:package "gen"))
     (propagated-inputs
-     `(("ocaml-odoc" ,(package-with-ocaml4.07 ocaml4.07-odoc))))
+     `(("ocaml-odoc" ,ocaml-odoc)))
     (native-inputs
-     `(("ocaml-qtest" ,(package-with-ocaml4.07 ocaml-qtest))
-       ("ocaml-qcheck" ,(package-with-ocaml4.07 ocaml-qcheck))))
+     `(("ocaml-qtest" ,ocaml-qtest)
+       ("ocaml-qcheck" ,ocaml-qcheck)))
     (home-page "https://github.com/c-cube/gen/")
     (synopsis "Iterators for OCaml, both restartable and consumable")
     (description "Gen implements iterators of OCaml, that are both restartable
@@ -2577,7 +2574,7 @@  and consumable.")
     (native-inputs
      `(("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))))
     (propagated-inputs
-     `(("ocaml-gen" ,ocaml4.07-gen)
+     `(("ocaml-gen" ,(package-with-ocaml4.07 ocaml-gen))
        ("ocaml-ppx-tools-versioned"
         ,(package-with-ocaml4.07 ocaml-ppx-tools-versioned))
        ("ocaml-uchar" ,(package-with-ocaml4.07 ocaml-uchar))))