diff mbox series

[bug#47737] gnu: Add tio

Message ID 20210412205150.10014-1-raphael.melotte@mind.be
State Accepted
Headers show
Series [bug#47737] gnu: Add tio | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raphaël Mélotte April 12, 2021, 8:51 p.m. UTC
* gnu/packages/terminals.scm (tio): New variable.

Signed-off-by: Raphaël Mélotte <raphael.melotte@mind.be>
---
 gnu/packages/terminals.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolas Goaziou April 26, 2021, 7 p.m. UTC | #1
Hello,

Raphaël Mélotte <raphael.melotte@mind.be> writes:

> * gnu/packages/terminals.scm (tio): New variable.

Applied. Thank you!

> Signed-off-by: Raphaël Mélotte <raphael.melotte@mind.be>

We don't sign our own patches. I signed it as the committer, however.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 3fe580589d..0031b4c482 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1436,3 +1437,23 @@  ephemeral serial ports.  It features automatic port detection, port enumeration,
 support for non-standard baud rates, the ability to wait for ports to appear,
 and the ability to read and write via stdin and stdout.")
     (license license:expat)))
+
+(define-public tio
+  (package
+    (name "tio")
+    (version "1.32")
+    (source (origin
+              (method url-fetch)
+             (uri (string-append
+                    "https://github.com/tio/tio/releases/download/v"
+                    version "/tio-" version ".tar.xz"))
+             (sha256
+              (base32
+               "0i5fhi4xdk4yznj8wahniizddmx6wlcnnhda1dw9djyajilyvxd8"))))
+    (build-system gnu-build-system)
+    (home-page "https://tio.github.io/")
+    (synopsis "Simple TTY terminal I/O application")
+    (description "tio is a simple TTY terminal application which features a
+straightforward commandline interface to easily connect to TTY devices for
+basic input/output.")
+    (license license:gpl2+)))