diff mbox series

[bug#47730,4/4] gnu: Add watson.

Message ID 20210412154852.10255-4-mail@sebastiangibb.de
State New
Headers show
Series gnu: add watson | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sebastian Gibb April 12, 2021, 3:48 p.m. UTC
* gnu/packages/time.scm (watson): New variable.
---
 gnu/packages/time.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

M April 12, 2021, 7:42 p.m. UTC | #1
On Mon, 2021-04-12 at 17:48 +0200, Sebastian Gibb via Guix-patches via wrote:
> [...]
> +     `(#:phases (modify-phases %standard-phases
> +                  (replace 'check
> +                    (lambda _
> +                      (invoke "pytest")
> +                      #t)))))

Phases do not need to return #t anymore.  The warning that results
if a phase doesn't return #t has been removed on the core-updates
branch, which will at some point in time be merged in master.

From a cursory look, I don't see any other problems, except perhaps ...

> +    (synopsis
> +     "Command-line time tracker")

I don't see a reason for a newline afer 'synopsis' here.

Thanks,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index dfade604a3..057c72b125 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -41,6 +41,8 @@ 
   #:use-module (gnu packages golang)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
+  #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages terminals)
   #:use-module (gnu packages textutils)
@@ -540,3 +542,42 @@  calls.")
 from a starting point you provide.  The user can pause and resume the
 countdown from the text user interface.")
     (license expat)))
+
+(define-public watson
+  (package
+    (name "watson")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tailordev/watson")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1yxqjirv7cpg4hqj4l3a53p3p3kl82bcx6drgvl9v849vcc3l7s0"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "pytest")
+                      #t)))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-datafiles" ,python-pytest-datafiles)
+       ("python-pytest-mock" ,python-pytest-mock)))
+    (inputs
+     `(("python-arrow" ,python-arrow)
+       ("python-click" ,python-click)
+       ("python-click-didyoumean" ,python-click-didyoumean)
+       ("python-colorama" ,python-colorama)
+       ("python-requests" ,python-requests)))
+    (home-page "https://tailordev.github.io/watson/")
+    (synopsis
+     "Command-line time tracker")
+    (description
+     "Watson is command-line interface to manage your time.  It supports
+     projects, tagging and reports.")
+    (license expat)))