diff mbox series

[bug#47725,1/1] gnu: emacs-counsel-projectile: Update to 0.3.1-0.06b03c1

Message ID 20210412131953.30891-1-mail@davie.li
State Accepted
Headers show
Series Update emacs-counsel-projectile (api change) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

David Dashyan April 12, 2021, 1:19 p.m. UTC
---
 gnu/packages/emacs-xyz.scm | 45 ++++++++++++++++++++------------------
 1 file changed, 24 insertions(+), 21 deletions(-)

Comments

Nicolas Goaziou April 26, 2021, 7:09 p.m. UTC | #1
Hello,

David Dashyan <mail@davie.li> writes:

> +  (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
> +        (revision "0"))
> +    (package
> +      (name "emacs-counsel-projectile")
> +      (version (git-version "0.3.1" revision commit))

Thank you.

I added a proper commit message to the patch, and a comment explaining
why we're not using stable release anymore.

Applied.

Regards,
David Dashyan April 27, 2021, 3:57 p.m. UTC | #2
Thanks! I'll include comments next time :)

Nicolas Goaziou writes:

> Hello,
>
> David Dashyan <mail@davie.li> writes:
>
>> +  (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
>> +        (revision "0"))
>> +    (package
>> +      (name "emacs-counsel-projectile")
>> +      (version (git-version "0.3.1" revision commit))
>
> Thank you.
>
> I added a proper commit message to the patch, and a comment explaining
> why we're not using stable release anymore.
>
> Applied.
>
> Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ca1daaeb82..19b61e721d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -96,6 +96,7 @@ 
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 David Dashyan <mail@davie.li>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8491,28 +8492,30 @@  asynchronously, with Counsel and Ivy.  Simply call
       (license license:gpl3+))))
 
 (define-public emacs-counsel-projectile
-  (package
-    (name "emacs-counsel-projectile")
-    (version "0.3.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/ericdanan/counsel-projectile")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1k4n5lw6wwbgpwv0dg9dw0bjzi0hvbgkzrs1zmq36yhfz6y8gwnh"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     `(("emacs-counsel" ,emacs-counsel)
-       ("emacs-projectile" ,emacs-projectile)))
-    (home-page "https://github.com/ericdanan/counsel-projectile")
-    (synopsis "Enhance Projectile with Ivy")
-    (description
-     "This package uses Ivy to provide additional actions for Projectile
+  (let ((commit "06b03c1080d3ccc3fa9b9c41b1ccbcf13f058e4b")
+        (revision "0"))
+    (package
+      (name "emacs-counsel-projectile")
+      (version (git-version "0.3.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ericdanan/counsel-projectile")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "10afil6grwxj1x8fxd3ar7ikw3s3hzrkjsjin8wzchbz04389l7s"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-counsel" ,emacs-counsel)
+         ("emacs-projectile" ,emacs-projectile)))
+      (home-page "https://github.com/ericdanan/counsel-projectile")
+      (synopsis "Enhance Projectile with Ivy")
+      (description
+       "This package uses Ivy to provide additional actions for Projectile
 commands and replacements for existing functions.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-qml-mode
   (package