diff mbox series

[bug#47643,staging,v2,9/9] gnu: gst-editing-services: Update to 1.18.4.

Message ID 20210412093614.9393-9-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#47643,staging,v2,1/9] gnu: gstreamer: Update to 1.18.4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler April 12, 2021, 9:36 a.m. UTC
From: Raghav Gururajan <rg@raghavgururajan.name>

* gnu/packages/gstreamer.scm (gst-editing-services)[version]: Update to 1.18.4.
[arguments](glib-or-gtk): New argument.
[inputs]: Add glib, glib-networking and gtk+. Move gst-plugins-base to ...
[propagated-inputs]: ... here. Add gstreamer.
[native-inputs]: Replace python with python-wrapper.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
 gnu/packages/gstreamer.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

Comments

M April 12, 2021, 2:57 p.m. UTC | #1
One question.

On Mon, 2021-04-12 at 11:36 +0200, Leo Prikler wrote:
>       ;; FIXME: 16/22 failing tests.

Is the number of failing tests the same after the package update?
If not so, what are the additional failing tests, or what tests
do pass now?

Warning: I didn't test this series, I'm just looking patches.
I'll try reconfiguring from "staging" when things are considered ready.

No other comments.

Greetings,
Maxime.
Leo Prikler April 12, 2021, 3:59 p.m. UTC | #2
Am Montag, den 12.04.2021, 16:57 +0200 schrieb Maxime Devos:
> One question.
> 
> On Mon, 2021-04-12 at 11:36 +0200, Leo Prikler wrote:
> >       ;; FIXME: 16/22 failing tests.
> 
> Is the number of failing tests the same after the package update?
> If not so, what are the additional failing tests, or what tests
> do pass now?
A minor correction, it would now be 16/23, but I don't think much
changed in the grand scheme of things.

> Warning: I didn't test this series, I'm just looking patches.
> I'll try reconfiguring from "staging" when things are considered
> ready.
Don't worry about it, I also look at aesthetics first.

Regards,
Leo
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index e4d7376cc3..6f649238d2 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -988,7 +988,7 @@  decoders, muxers, and demuxers provided by FFmpeg.")
 (define-public gst-editing-services
   (package
     (name "gst-editing-services")
-    (version "1.18.2")
+    (version "1.18.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -996,15 +996,21 @@  decoders, muxers, and demuxers provided by FFmpeg.")
                     "gst-editing-services-" version ".tar.xz"))
               (sha256
                (base32
-                "0pv2k8zlpn3vv2sdlspi3m63ixcwzi90pjly2ypbkg59ab97rb15"))))
+                "010xg960qsh5dwmf0y9l1q13h0cymmrgapzla2zsw66ylxqbi1s6"))))
     (build-system meson-build-system)
     (arguments
      ;; FIXME: 16/22 failing tests.
      `(#:tests? #f
+       #:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:phases (modify-phases %standard-phases
                   ,@%common-gstreamer-phases)))
+    (propagated-inputs
+     `(("gstreamer" ,gstreamer)
+       ("gst-plugins-base" ,gst-plugins-base)))
     (inputs
-     `(("gst-plugins-base" ,gst-plugins-base)
+     `(("glib" ,glib)
+       ("glib-networking" ,glib-networking)
+       ("gtk+" ,gtk+)
        ("libxml2" ,libxml2)))
     (native-inputs
      `(("flex" ,flex)
@@ -1014,7 +1020,7 @@  decoders, muxers, and demuxers provided by FFmpeg.")
        ("gst-plugins-good" ,gst-plugins-good)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("python" ,python)))
+       ("python" ,python-wrapper)))
     (home-page "https://gstreamer.freedesktop.org/")
     (synopsis "GStreamer library for non-linear editors")
     (description