diff mbox series

[bug#47726] gnu: Add vice emulator

Message ID 20210412081126.165435-1-balbi@kernel.org
State Accepted
Headers show
Series [bug#47726] gnu: Add vice emulator | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felipe Balbi April 12, 2021, 8:11 a.m. UTC
From: Felipe Balbi <balbi@kernel.org>

* gnu/packages/emulators.scm (vice): New variable.

Signed-off-by: Felipe Balbi <balbi@kernel.org>
---
 gnu/packages/emulators.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Nicolas Goaziou April 26, 2021, 6:55 p.m. UTC | #1
Hello,

balbi@kernel.org writes:

> From: Felipe Balbi <balbi@kernel.org>
>
> * gnu/packages/emulators.scm (vice): New variable.

Thank you! I applied it.

> Signed-off-by: Felipe Balbi <balbi@kernel.org>

We don't have the habit of signing our own patches.

> +       (uri (string-append "mirror://sourceforge/vice-emu/releases/"
> +                           name "-" version ".tar.gz"))

Nitpick: we hard-code the name in the URI.

Regards,
Felipe Balbi April 26, 2021, 6:57 p.m. UTC | #2
Hi,

On Mon, Apr 26, 2021 at 9:55 PM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
> Hello,
>
> balbi@kernel.org writes:
>
> > From: Felipe Balbi <balbi@kernel.org>
> >
> > * gnu/packages/emulators.scm (vice): New variable.
>
> Thank you! I applied it.

Awesome, thanks :-)

> > Signed-off-by: Felipe Balbi <balbi@kernel.org>
>
> We don't have the habit of signing our own patches.
>
> > +       (uri (string-append "mirror://sourceforge/vice-emu/releases/"
> > +                           name "-" version ".tar.gz"))
>
> Nitpick: we hard-code the name in the URI.

sure thing, I'll keep that in mind next time :-)

I did see a couple packages doing that, though.
diff mbox series

Patch

diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 8482f679e2c3..5c41e0fc22cb 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2021 Felipe Balbi <balbi@kernel.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -44,6 +45,7 @@ 
   #:use-module (gnu packages autogen)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages cdrom)
@@ -53,6 +55,7 @@ 
   #:use-module (gnu packages curl)
   #:use-module (gnu packages digest)
   #:use-module (gnu packages elf)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
@@ -97,6 +100,45 @@ 
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python))
 
+(define-public vice
+  (package
+    (name "vice")
+    (version "3.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/vice-emu/releases/"
+                           name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "03nwcldg2h7dxj6aa77ggqc0442hqc1lsq5x69h8kcmqmvx7ifan"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--disable-pdf-docs")))
+    (native-inputs
+     `(("bison" ,bison)
+       ("dos2unix" ,dos2unix)
+       ("flex" ,flex)
+       ("glib" ,glib "bin")             ; for glib-genmarshal, etc.
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("glew" ,glew)
+       ("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("pulseaudio" ,pulseaudio)
+       ("sdl" ,sdl)
+       ("sdl-image" ,sdl-image)
+       ("xa" ,xa)))
+    (home-page "https://vice-emu.sourceforge.io/")
+    (synopsis "The Versatile Commodore Emulator")
+    (description
+     "VICE is a program that emulates the C64, the C64DTV, the C128, the
+VIC20, practically all PET models, the PLUS4 and the CBM-II (aka
+C610/C510).  An extra emulator is provided for C64 expanded with the CMD
+SuperCPU.")
+    (license license:gpl2+)))
+
 (define-public desmume
   (package
     (name "desmume")