diff mbox series

[bug#47508] gnu: add instead

Message ID 20210330235329.792240-1-krotov@iitp.ru
State Accepted
Headers show
Series [bug#47508] gnu: add instead | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Alexander Krotov March 30, 2021, 11:53 p.m. UTC
* gnu/packages/games.scm (instead): New variable.
---
 gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Leo Prikler April 5, 2021, 4:42 p.m. UTC | #1
merge 46378 47508
thanks

Hi,

as you can see, there does exist prior work on the packaging of
instead.  Dmitry's patch also includes a search path among other
things, but there were some setbacks, that are discussed over there. 
Work on that patch seems to have come to a halt, but it would be great
if you could try to see what could be salvaged from it.

Regards,
Leo

Am Mittwoch, den 31.03.2021, 02:53 +0300 schrieb Alexander Krotov:
> * gnu/packages/games.scm (instead): New variable.
> ---
>  gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 3f909aad4b..22975cf0d6 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -12379,3 +12379,34 @@ game FPS.")
>  implemented using ncurses user interface.  An SDL graphical version
> is also
>  available.")
>      (license license:gpl3+)))
> +
> +(define-public instead
> +  (package
> +    (name "instead")
> +    (version "3.3.4")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/instead-hub/instead")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> "09z22i0ny3dhjhj3g1walxg5mdnr3wsx95q1f92z32cabmqkbiyc"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f))
> +    (inputs `(("zlib" ,zlib)
> +              ("lua" ,lua)
> +              ("sdl2" ,sdl2)
> +              ("sdl2-mixer" ,sdl2-mixer)
> +              ("sdl2-image" ,sdl2-image)
> +              ("sdl2-ttf" ,sdl2-ttf)
> +              ("gtk+" ,gtk+)))
> +    (native-inputs `(("pkg-config" ,pkg-config)))
> +    (home-page "https://instead.hugeping.ru/")
> +    (synopsis "Simple text adventures/visual novels engine")
> +    (description "INSTEAD is an INterpreter of Simple TExt
> ADventure.  Using
> +INSTEAD you can create and play games that could be classified as a
> mix of
> +visual novel and text quest.")
> +    (license license:expat)))
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 3f909aad4b..22975cf0d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -12379,3 +12379,34 @@  game FPS.")
 implemented using ncurses user interface.  An SDL graphical version is also
 available.")
     (license license:gpl3+)))
+
+(define-public instead
+  (package
+    (name "instead")
+    (version "3.3.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/instead-hub/instead")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09z22i0ny3dhjhj3g1walxg5mdnr3wsx95q1f92z32cabmqkbiyc"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (inputs `(("zlib" ,zlib)
+              ("lua" ,lua)
+              ("sdl2" ,sdl2)
+              ("sdl2-mixer" ,sdl2-mixer)
+              ("sdl2-image" ,sdl2-image)
+              ("sdl2-ttf" ,sdl2-ttf)
+              ("gtk+" ,gtk+)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://instead.hugeping.ru/")
+    (synopsis "Simple text adventures/visual novels engine")
+    (description "INSTEAD is an INterpreter of Simple TExt ADventure.  Using
+INSTEAD you can create and play games that could be classified as a mix of
+visual novel and text quest.")
+    (license license:expat)))