diff mbox series

[bug#47477] gnu: crypto++: Update to 8.5.0.

Message ID 20210329155946.19273-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#47477] gnu: crypto++: Update to 8.5.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler March 29, 2021, 3:59 p.m. UTC
* gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
[origin]: Use git-fetch and git-reference.
---
 gnu/packages/crypto.scm | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)

Comments

Ludovic Courtès April 5, 2021, 9:47 a.m. UTC | #1
Hi Leo,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

> * gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
> [origin]: Use git-fetch and git-reference.

If dependents still build fine, go for it!

Thanks,
Ludo’.
Leo Prikler April 5, 2021, 2:18 p.m. UTC | #2
Am Montag, den 05.04.2021, 11:47 +0200 schrieb Ludovic Courtès:
> Hi Leo,
> 
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
> 
> > * gnu/packages/crypto.scm (crypto++): Update to 8.5.0.
> > [origin]: Use git-fetch and git-reference.
> 
> If dependents still build fine, go for it!
> 
> Thanks,
> Ludo’.
Built everything locally and pushed.  Hopefully the CI doesn't notice,
that I only checked amd64 :)
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 94f9cbeebf..57d417de80 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -773,15 +773,18 @@  data on your platform, so the seed itself will be as random as possible.
 (define-public crypto++
   (package
     (name "crypto++")
-    (version "8.4.0")
+    (version "8.5.0")
     (source (origin
-              (method url-fetch/zipbomb)
-              (uri (string-append "https://cryptopp.com/cryptopp"
-                                  (string-join (string-split version #\.) "")
-                                  ".zip"))
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/weidai11/cryptopp")
+                (commit
+                 (string-append "CRYPTOPP_"
+                                (string-replace-substring version "." "_")))))
               (sha256
                (base32
-                "16kvfm11xv7j9a3yykzysjgw38a9b7lnc5n5x5h82g395k6ybxf0"))))
+                "0in7rlazq91vfi519g9wr7bh87hii47cimxv7fmj0f88vhjaidq3"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags