diff mbox series

[bug#47465] Added wlrctl to xdisorg

Message ID 20210329105622.5812-1-calumirwin1@gmail.com
State New
Headers show
Series [bug#47465] Added wlrctl to xdisorg | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Calum Irwin March 29, 2021, 10:56 a.m. UTC
---
 gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

M March 29, 2021, 1:50 p.m. UTC | #1
Hi,

On Mon, 2021-03-29 at 23:56 +1300, calum wrote:
> ---
>  gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)

Please include a commit message.  There are plenty of examples
in the git history to base you on.  Also see section
16.6 ‘Submitting Patches’ of the manual.

> diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> index 56ac53edec..6d936efee6 100644
> --- a/gnu/packages/xdisorg.scm
> +++ b/gnu/packages/xdisorg.scm
> @@ -80,6 +80,7 @@

You should add a copyright line.

>    #:use-module (gnu packages base)
>    #:use-module (gnu packages bison)
>    #:use-module (gnu packages check)
> +  #:use-module (gnu packages cmake)
>    #:use-module (gnu packages compression)
>    #:use-module (gnu packages documentation)
>    #:use-module (gnu packages flex)
> @@ -2788,3 +2789,33 @@ and execute @file{.desktop} files of the Application type.")
>       "The @command{hsetroot} command composes wallpapers for X.
>  This package is the fork of hsetroot by Hyriand.")
>      (license license:gpl2+)))
> +
> +(define-public wlrctl
> +  (package
> +    (name "wlrctl")
> +    (version "0.2.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://git.sr.ht/~brocellous/wlrctl")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
> +    (build-system meson-build-system)
> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)
> +       ("cmake" ,cmake)
> +       ("scdoc" ,scdoc)))
> +    (inputs
> +     `(("libxkbcommon" ,libxkbcommon)
> +       ("wayland" ,wayland)))

If this is a wayland package, shouldn't this be in (gnu packages freedesktop)?
I'm not sure myself where it should be, but at least that's were the 'wayland'
package resides.

> +    (home-page "https://git.sr.ht/~brocellous/wlrctl")
> +    (synopsis "Command line utility for wlroots automation and extensions")
> +    (description
> +     "wlrctl is a command line utility for miscellaneous wlroots Wayland
> +extensions.  At this time, wlrctl supports the foreign-toplevel-mangement
> +(window/toplevel command), virtual-keyboard (keyboard command),
> +and virtual-pointer (pointer command) protocols.")
> +    (license license:expat)))

The package definition seems about right to me, but I don't have time to
actually test this.

Greetings,
Maxime.
Calum Irwin March 30, 2021, 10:32 a.m. UTC | #2
freedesktop.scm seemed to be more for libraries while xdisorg was for
miscellaneous applications and there were already a number of wayland
specific applications in there (redshift-wayland, gammastep,
bemenu...)

As an aside, if you're a maintainer for the repo you may want to take
a quick look at the README and HACKING documents which mention a
doc/guix.info which looks to have been replaced with a texi file that
info doesn't support the MENU-ITEM jumping to, for example,
"Contributing" or "Building from git".

Apologies if the commit message is screwed up again. It's supposed to say:

gnu: Add wlrctl

* gnu/packages/xdisorg.scm (wlrctl): New variables.

On Tue, Mar 30, 2021 at 2:50 AM Maxime Devos <maximedevos@telenet.be> wrote:
>
> Hi,
>
> On Mon, 2021-03-29 at 23:56 +1300, calum wrote:
> > ---
> >  gnu/packages/xdisorg.scm | 31 +++++++++++++++++++++++++++++++
> >  1 file changed, 31 insertions(+)
>
> Please include a commit message.  There are plenty of examples
> in the git history to base you on.  Also see section
> 16.6 ‘Submitting Patches’ of the manual.
>
> > diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
> > index 56ac53edec..6d936efee6 100644
> > --- a/gnu/packages/xdisorg.scm
> > +++ b/gnu/packages/xdisorg.scm
> > @@ -80,6 +80,7 @@
>
> You should add a copyright line.
>
> >    #:use-module (gnu packages base)
> >    #:use-module (gnu packages bison)
> >    #:use-module (gnu packages check)
> > +  #:use-module (gnu packages cmake)
> >    #:use-module (gnu packages compression)
> >    #:use-module (gnu packages documentation)
> >    #:use-module (gnu packages flex)
> > @@ -2788,3 +2789,33 @@ and execute @file{.desktop} files of the Application type.")
> >       "The @command{hsetroot} command composes wallpapers for X.
> >  This package is the fork of hsetroot by Hyriand.")
> >      (license license:gpl2+)))
> > +
> > +(define-public wlrctl
> > +  (package
> > +    (name "wlrctl")
> > +    (version "0.2.1")
> > +    (source (origin
> > +              (method git-fetch)
> > +              (uri (git-reference
> > +                    (url "https://git.sr.ht/~brocellous/wlrctl")
> > +                    (commit (string-append "v" version))))
> > +              (file-name (git-file-name name version))
> > +              (sha256
> > +               (base32
> > +                "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
> > +    (build-system meson-build-system)
> > +    (native-inputs
> > +     `(("pkg-config" ,pkg-config)
> > +       ("cmake" ,cmake)
> > +       ("scdoc" ,scdoc)))
> > +    (inputs
> > +     `(("libxkbcommon" ,libxkbcommon)
> > +       ("wayland" ,wayland)))
>
> If this is a wayland package, shouldn't this be in (gnu packages freedesktop)?
> I'm not sure myself where it should be, but at least that's were the 'wayland'
> package resides.
>
> > +    (home-page "https://git.sr.ht/~brocellous/wlrctl")
> > +    (synopsis "Command line utility for wlroots automation and extensions")
> > +    (description
> > +     "wlrctl is a command line utility for miscellaneous wlroots Wayland
> > +extensions.  At this time, wlrctl supports the foreign-toplevel-mangement
> > +(window/toplevel command), virtual-keyboard (keyboard command),
> > +and virtual-pointer (pointer command) protocols.")
> > +    (license license:expat)))
>
> The package definition seems about right to me, but I don't have time to
> actually test this.
>
> Greetings,
> Maxime.
>
Leo Famulari April 4, 2021, 5:49 p.m. UTC | #3
On Tue, Mar 30, 2021 at 11:32:05PM +1300, Calum Irwin wrote:
> As an aside, if you're a maintainer for the repo you may want to take
> a quick look at the README and HACKING documents which mention a
> doc/guix.info which looks to have been replaced with a texi file that
> info doesn't support the MENU-ITEM jumping to, for example,
> "Contributing" or "Building from git".

Do you mean that, in the Git repo, you can only find the 'doc/guix.texi'
file, and that guix.info is missing?

If so, that's expected.

'guix.info' is built from 'guix.texi', by doing `make doc/guix.info`.

You can also do, for example, `make doc/guix.html`.
Calum Irwin June 27, 2021, 4:30 a.m. UTC | #4
I've updated the patch to no longer conflict with the latest master.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 56ac53edec..6d936efee6 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -80,6 +80,7 @@ 
   #:use-module (gnu packages base)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
@@ -2788,3 +2789,33 @@  and execute @file{.desktop} files of the Application type.")
      "The @command{hsetroot} command composes wallpapers for X.
 This package is the fork of hsetroot by Hyriand.")
     (license license:gpl2+)))
+
+(define-public wlrctl
+  (package
+    (name "wlrctl")
+    (version "0.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~brocellous/wlrctl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "039cxc82k7x473n6d65jray90rj35qmfdmr390zy0c7ic7vn4b78"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("cmake" ,cmake)
+       ("scdoc" ,scdoc)))
+    (inputs
+     `(("libxkbcommon" ,libxkbcommon)
+       ("wayland" ,wayland)))
+    (home-page "https://git.sr.ht/~brocellous/wlrctl")
+    (synopsis "Command line utility for wlroots automation and extensions")
+    (description
+     "wlrctl is a command line utility for miscellaneous wlroots Wayland
+extensions.  At this time, wlrctl supports the foreign-toplevel-mangement
+(window/toplevel command), virtual-keyboard (keyboard command),
+and virtual-pointer (pointer command) protocols.")
+    (license license:expat)))