diff mbox series

[bug#47433,v2,2/2] gnu: Add lagrange.

Message ID 20210328154943.21575-3-lle-bout@zaclys.net
State Accepted
Headers show
Series gnu: Add lagrange. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter March 28, 2021, 3:49 p.m. UTC
* gnu/packages/web.scm (lagrange): New variable.
---
 gnu/packages/web.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7896094726..5edb720a41 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -143,6 +143,7 @@ 
   #:use-module (gnu packages mail)
   #:use-module (gnu packages man)
   #:use-module (gnu packages markup)
+  #:use-module (gnu packages mp3)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages networking)
   #:use-module (gnu packages nss)
@@ -160,6 +161,7 @@ 
   #:use-module (gnu packages qt)
   #:use-module (gnu packages re2c)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages sdl)
   #:use-module (gnu packages search)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages texinfo)
@@ -6675,6 +6677,45 @@  point of view of someone who appreciates the user-friendliness of Qt and some
 of the thinking behind C++ STL.")
       (license license:bsd-2))))
 
+;; When upgrading, also upgrade the "the-foundation" package just above.
+;; Lagrange pins specific commits of it and "the-foundation" does not make
+;; releases (yet?).
+(define-public lagrange
+  (package
+    (name "lagrange")
+    (version "1.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.skyjake.fi/skyjake/lagrange")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0djwr0n06z993kdpvks1dj7nr4j6481sfh5mjjg7q2hsfnsj9kmx"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (delete-file-recursively "lib/the_Foundation")
+                  #t))))
+    (build-system cmake-build-system)
+    (arguments
+     `(;; No tests
+       #:tests? #f))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("the-foundation" ,the-foundation)
+       ("sdl2" ,sdl2)
+       ("mpg123" ,mpg123)))
+    (home-page "https://gmi.skyjake.fi/lagrange/")
+    (synopsis "Beautiful desktop GUI client for browsing Geminispace")
+    (description "@code{Lagrange} is a desktop GUI client for browsing
+Geminispace.  It offers modern conveniences familiar from web browsers, such
+as smooth scrolling, inline image viewing, multiple tabs, visual themes,
+Unicode fonts, bookmarks, history, and page outlines.")
+    (license license:bsd-2)))
+
 (define-public python-py-ubjson
   (package
     (name "python-py-ubjson")