diff mbox series

[bug#47415,1/2] gnu: Move libgme to audio.scm.

Message ID 20210326181630.17136-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Add missing inputs to gst-plugins-bad | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler March 26, 2021, 6:16 p.m. UTC
* gnu/packages/music.scm (libgme): Move from here...
* gnu/packages/audio.scm (libgme): ... to here.
---
 gnu/packages/audio.scm | 44 ++++++++++++++++++++++++++++++++++++++++++
 gnu/packages/music.scm | 44 ------------------------------------------
 2 files changed, 44 insertions(+), 44 deletions(-)

Comments

Maxim Cournoyer Oct. 2, 2021, 4:55 a.m. UTC | #1
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/music.scm (libgme): Move from here...
> * gnu/packages/audio.scm (libgme): ... to here.

Applied to staging as I was working through gstreamer.  Thank you.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 29ef0266ce..3a2dbcc579 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -403,6 +403,50 @@  by MusicIP.")
       ;; Others.
       license:lgpl2.0+))))
 
+(define-public libgme
+  (package
+    (name "libgme")
+    (version "0.6.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
+                                  "downloads/game-music-emu-" version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "07857vdkak306d9s5g6fhmjyxk7vijzjhkmqb15s7ihfxx9lx8xb"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f))                    ; no check target
+    (home-page "https://bitbucket.org/mpyne/game-music-emu")
+    (synopsis "Video game music file playback library")
+    (description
+     "Game-music-emu is a collection of video game music file emulators that
+support the following formats and systems:
+@table @code
+@item AY
+ZX Spectrum/Asmtrad CPC
+@item GBS
+Nintendo Game Boy
+@item GYM
+Sega Genesis/Mega Drive
+@item HES
+NEC TurboGrafx-16/PC Engine
+@item KSS
+MSX Home Computer/other Z80 systems (doesn't support FM sound)
+@item NSF/NSFE
+Nintendo NES/Famicom (with VRC 6, Namco 106, and FME-7 sound)
+@item SAP
+Atari systems using POKEY sound chip
+@item SPC
+Super Nintendo/Super Famicom
+@item VGM/VGZ
+Sega Master System/Mark III, Sega Genesis/Mega Drive, BBC Micro
+@end table")
+    (license (list license:lgpl2.1+
+                   ;; demo and player directories are under the Expat license
+                   license:expat))))
+
 (define-public libtimidity
   (package
     (name "libtimidity")
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 98cd3583cc..9bb354f201 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1293,50 +1293,6 @@  for path in [path for path in sys.path if 'site-packages' in path]: site.addsite
 interface.  It is implemented as a frontend to @code{klick}.")
     (license license:gpl2+)))
 
-(define-public libgme
-  (package
-    (name "libgme")
-    (version "0.6.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
-                                  "downloads/game-music-emu-" version
-                                  ".tar.xz"))
-              (sha256
-               (base32
-                "07857vdkak306d9s5g6fhmjyxk7vijzjhkmqb15s7ihfxx9lx8xb"))))
-    (build-system cmake-build-system)
-    (arguments
-     '(#:tests? #f))                    ; no check target
-    (home-page "https://bitbucket.org/mpyne/game-music-emu")
-    (synopsis "Video game music file playback library")
-    (description
-     "Game-music-emu is a collection of video game music file emulators that
-support the following formats and systems:
-@table @code
-@item AY
-ZX Spectrum/Asmtrad CPC
-@item GBS
-Nintendo Game Boy
-@item GYM
-Sega Genesis/Mega Drive
-@item HES
-NEC TurboGrafx-16/PC Engine
-@item KSS
-MSX Home Computer/other Z80 systems (doesn't support FM sound)
-@item NSF/NSFE
-Nintendo NES/Famicom (with VRC 6, Namco 106, and FME-7 sound)
-@item SAP
-Atari systems using POKEY sound chip
-@item SPC
-Super Nintendo/Super Famicom
-@item VGM/VGZ
-Sega Master System/Mark III, Sega Genesis/Mega Drive, BBC Micro
-@end table")
-    (license (list license:lgpl2.1+
-                   ;; demo and player directories are under the Expat license
-                   license:expat))))
-
 (define-public ninjas2
   (package
     (name "ninjas2")