diff mbox series

[bug#47350,v2,19/30] gnu: Add julia-commonsubexpressions.

Message ID 20210325010516.18994-18-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#47350,v2,01/30] build: julia-build-system: Turn on depreciation warnings. | expand

Commit Message

Simon Tournier March 25, 2021, 1:05 a.m. UTC
* gnu/packages/julia-xyz.scm (julia-commonsubexpressions): New variable.
---
 gnu/packages/julia-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e3d2c9ff89..c5c04d6579 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -230,6 +230,28 @@  constructors, and sets up traits and show methods to make them easier to work
 with.")
     (license license:expat)))
 
+(define-public julia-commonsubexpressions
+  (package
+    (name "julia-commonsubexpressions")
+    (version "0.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rdeits/CommonSubexpressions.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0mgy90kk8ksv3l720kkk04gnhn4aqhh2dj4sp3x8yy3limngfjay"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-macrotools" ,julia-macrotools)))
+    (home-page "https://github.com/rdeits/CommonSubexpressions.jl")
+    (synopsis "Macro @code{@cse}")
+    (description "This package provides the @code{@cse} macro, which performs
+common subexpression elimination.")
+    (license license:expat)))
+
 (define-public julia-compat
   (package
     (name "julia-compat")