diff mbox series

[bug#47350,10/29] gnu: Add julia-colors.

Message ID 20210323194641.18110-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add Zygote (piece for Machine Learning with Julia) | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 23, 2021, 7:46 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-colors): New variable.
---
 gnu/packages/julia-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3213efd715..84c98b32af 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -121,6 +121,46 @@  operations.  It can wrap any @code{IO} type automatically making incremental
 reading and writing faster.")
     (license license:expat)))
 
+(define-public julia-colors
+  (package
+    (name "julia-colors")
+    (version "0.12.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaGraphics/Colors.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "156zsszgwh6bmznsan0zyha6yvcxw3c5mvc5vr2qfsgxbyh36ln6"))))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-test
+           (lambda _
+             (substitute* "test/parse.jl"
+               (("@test_logs \\(:warn, r\"Use \\\\\"SeaGreen\\\\\" or \\\\\"seagreen\\\\\"\"\\)")
+                ""))
+             (substitute* "test/utilities.jl"
+               (("@test_logs \\(:warn, r\"Base\\\\\\.hex\\\\\\(c\\\\\\) has been moved\"\\)")
+                "")
+               (("@test_logs \\(:warn, r\"will soon be changed\"\\)")
+                ""))
+             #t)))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-colortypes" ,julia-colortypes)
+       ("julia-fixedpointnumbers" ,julia-fixedpointnumbers)
+       ("julia-reexport" ,julia-reexport)))
+    (home-page "https://github.com/JuliaGraphics/Colors.jl")
+    (synopsis "Tools for dealing with color")
+    (description "This package provides a wide array of functions for dealing
+with color.  This includes conversion between colorspaces, measuring distance
+between colors, simulating color blindness, parsing colors, and generating
+color scales for graphics.")
+    (license license:expat)))
+
 (define-public julia-colortypes
   (package
     (name "julia-colortypes")