diff mbox series

[bug#47332,2/2] Enable test of minetest

Message ID 20210323002804.4050-1-lasnesne@lagunposprasihopre.org
State Accepted
Headers show
Series None | expand

Commit Message

la snesne March 23, 2021, 12:28 a.m. UTC
---
 gnu/packages/games.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

Comments

Leo Prikler March 23, 2021, 10:53 a.m. UTC | #1
Hi,

Am Dienstag, den 23.03.2021, 09:06 +0900 schrieb la snesne:
> -    (version "5.3.0")
> +    (version "5.4.0")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -3473,7 +3473,7 @@ match, cannon keep, and grave-itation pit.")
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -                "03ga3j3cg38w4lg4d4qxasmnjdl8n3lbizidrinanvyfdyvznyh
> 6"))
> +                "1a17g6cmxrscnqwpwrd4w2ck3dgvplyfq4kzyimilfpqar1q69j
> 9"))
>                (modules '((guix build utils)))
>                (snippet
>                 '(begin
> @@ -3541,7 +3541,7 @@ in different ways.")
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -                "1liciwlh013z5h08ib0psjbwn5wkvlr937ir7kslfk4vly984cj
> x"))))
> +                "11dz36z0pj2r7i8xm8v5lskzws81ckj6sc0avlmvdl8qdc9x83w
> 5"))))
Applied with changes to the commit message.

Am Dienstag, den 23.03.2021, 09:28 +0900 schrieb la snesne:
> ---
>  gnu/packages/games.scm | 12 ++++++++++--
>  1 file changed, 10 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index f1ee7e9971..0ccbde636a 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -3482,7 +3482,7 @@ match, cannon keep, and grave-itation pit.")
>                    #t))))
>      (build-system cmake-build-system)
>      (arguments
> -     '(#:configure-flags
> +     `(#:configure-flags
>         (list "-DRUN_IN_PLACE=0"
>               "-DENABLE_FREETYPE=1"
>               "-DENABLE_GETTEXT=1"
> @@ -3493,7 +3493,15 @@ match, cannon keep, and grave-itation pit.")
>               (string-append "-DCURL_INCLUDE_DIR="
>                              (assoc-ref %build-inputs "curl")
>                              "/include/curl"))
> -       #:tests? #f))                    ;no check target
> +       #:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda _
> +             (setenv "HOME" "/tmp")
> +             (invoke (string-append "../" ,name "-" ,version
> +                                    "-checkout/bin/minetest")
> +                     "--run-unittests")
> +             #t)))))
>      (native-search-paths
>       (list (search-path-specification
>              (variable "MINETEST_SUBGAME_PATH")
Instead of constructing the name like you did, I patched CMakeLists to
put the binaries into the build folder.  I also ensured, that cross-
compilation would work (like Maxime said) and that unittests can
meaningfully be executed after installation.  Finally, as before, I
rewrote the commit message.

The changed patches are now upstream as of
7fc1fac64a8d800d651f55a80ff158abd7a90ccb.

Regards,
Leo
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f1ee7e9971..0ccbde636a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3482,7 +3482,7 @@  match, cannon keep, and grave-itation pit.")
                   #t))))
     (build-system cmake-build-system)
     (arguments
-     '(#:configure-flags
+     `(#:configure-flags
        (list "-DRUN_IN_PLACE=0"
              "-DENABLE_FREETYPE=1"
              "-DENABLE_GETTEXT=1"
@@ -3493,7 +3493,15 @@  match, cannon keep, and grave-itation pit.")
              (string-append "-DCURL_INCLUDE_DIR="
                             (assoc-ref %build-inputs "curl")
                             "/include/curl"))
-       #:tests? #f))                    ;no check target
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (setenv "HOME" "/tmp")
+             (invoke (string-append "../" ,name "-" ,version
+                                    "-checkout/bin/minetest")
+                     "--run-unittests")
+             #t)))))
     (native-search-paths
      (list (search-path-specification
             (variable "MINETEST_SUBGAME_PATH")