diff mbox series

[bug#47269,1/1] gnu: Add node-global-gradle-clean.

Message ID 20210322125916.21038-2-contact@dhruvin.dev
State New
Headers show
Series gnu: Add node-global-gradle-clean | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Dhruvin Gandhi March 22, 2021, 12:59 p.m. UTC
* gnu/packages/node-xyz.scm (node-global-gradle-clean): New variable.
---
 gnu/packages/node-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index b1d6d4ce59..98f91e07f7 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -98,6 +99,30 @@  multiple node.js files, while providing useful information about output and exit
 codes.")
     (license license:expat)))
 
+(define-public node-global-gradle-clean
+  (package
+   (name "node-global-gradle-clean")
+   (version "1.0.1")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://github.com/VarunBarad/global-gradle-clean")
+           (commit version)))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "1fhm4jimnf7bl5drgwg39mjh8x4rns15hl0fz3bnxi9ikc6dm02y"))))
+   (build-system node-build-system)
+   (arguments '(#:tests? #f)) ; No tests.
+   (home-page "https://github.com/VarunBarad/global-gradle-clean")
+   (synopsis "Global Gradle Clean")
+   (description
+    "Global Gradle Clean is a Node.js package used to clean all gradle
+projects under a given directory.  It uses the gradle wrapper to execute the
+clean task of each project.")
+   (license license:expat)))
+
 (define-public node-long-stack-traces
   (package
     (name "node-long-stack-traces")