diff mbox series

[bug#47153,v3,1/3] gnu: chez-scheme: Update nanopass to 1.9.2.

Message ID 20210319182451.840-1-philip@philipmcgrath.com
State Accepted
Headers show
Series [bug#47153,v3,1/3] gnu: chez-scheme: Update nanopass to 1.9.2. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath March 19, 2021, 6:24 p.m. UTC
* gnu/packages/chez.scm (nanopass): Update nanopass to 1.9.2.
---
 gnu/packages/chez.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès April 5, 2021, 10:02 a.m. UTC | #1
Hi Leo,

If this v3 looks good to you, please push.  :-)

One nitpick:

Philip McGrath <philip@philipmcgrath.com> skribis:

> -      (sha256 (base32 "1synadgaycca39jfx525975ss9y0lkl516sdrc62wrrllamm8n21"))
> +      (sha256 "16vjsik9rrzbabbhbxbaha51ppi3f9n8rk59pc6zdyffs0vziy4i")

Before pushing, please keep the (base32 …) forms (here and elsewhere).
That they can be removed is not intended.

Thanks Leo and Philip,
Ludo’.
Leo Prikler April 5, 2021, 2:20 p.m. UTC | #2
Am Montag, den 05.04.2021, 12:02 +0200 schrieb Ludovic Courtès:
> Hi Leo,
> 
> If this v3 looks good to you, please push.  :-)
Ah, sorry.  I totally missed v3, because I wasn't CC'd.

> One nitpick:
> 
> Philip McGrath <philip@philipmcgrath.com> skribis:
> 
> > -      (sha256 (base32
> > "1synadgaycca39jfx525975ss9y0lkl516sdrc62wrrllamm8n21"))
> > +      (sha256
> > "16vjsik9rrzbabbhbxbaha51ppi3f9n8rk59pc6zdyffs0vziy4i")
> 
> Before pushing, please keep the (base32 …) forms (here and
> elsewhere).
> That they can be removed is not intended.
> 
Done and pushed.

Regards,
Leo
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index eac556c4d0..5dd1185c43 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,13 +44,13 @@ 
   #:use-module (srfi srfi-1))
 
 (define nanopass
-  (let ((version "1.9.1"))
+  (let ((version "1.9.2"))
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/nanopass/nanopass-framework-scheme")
             (commit (string-append "v" version))))
-      (sha256 (base32 "1synadgaycca39jfx525975ss9y0lkl516sdrc62wrrllamm8n21"))
+      (sha256 "16vjsik9rrzbabbhbxbaha51ppi3f9n8rk59pc6zdyffs0vziy4i")
       (file-name (git-file-name "nanopass" version)))))
 
 (define stex