diff mbox series

[bug#47171,v2,1/3] gnu: r-bisquerna: Move to (gnu packages bioconductor).

Message ID 20210317201414.10811-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#47171,v2,1/3] gnu: r-bisquerna: Move to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 17, 2021, 8:14 p.m. UTC
* gnu/packages/cran.scm (r-bisquerna): Move this variable from here...
* gnu/packages/bioconductor.scm (r-bisquerna): ...to here.
---
 gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
 gnu/packages/cran.scm         | 25 -------------------------
 2 files changed, 26 insertions(+), 25 deletions(-)


base-commit: d79d63e7829d53f6a501d8df7e264ff70033abca

Comments

Ricardo Wurmus March 31, 2021, 7:29 p.m. UTC | #1
Thanks for this new patch set.  I applied it and ran “make
as-derivation” without problems.

I pushed these three commits to the master branch.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d611f3a491..b5ac2750f3 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1294,6 +1294,32 @@  naming and share the same rich and consistent \"Vector API\" as much as
 possible.")
     (license license:artistic2.0)))
 
+;; This is a CRAN package, but it depends on r-biobase from Bioconductor.
+(define-public r-bisquerna
+  (package
+   (name "r-bisquerna")
+   (version "1.0.4")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "BisqueRNA" version))
+            (sha256
+             (base32
+              "01g34n87ml7n3pck77497ddgbv3rr5p4153ac8ninpgjijlm3jw2"))))
+   (properties `((upstream-name . "BisqueRNA")))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-biobase" ,r-biobase)
+      ("r-limsolve" ,r-limsolve)))
+   (home-page "https://www.biorxiv.org/content/10.1101/669911v1")
+   (synopsis "Decomposition of bulk expression with single-cell sequencing")
+   (description "This package provides tools to accurately estimate cell type
+abundances from heterogeneous bulk expression.  A reference-based method
+utilizes single-cell information to generate a signature matrix and
+transformation of bulk expression for accurate regression based estimates.
+A marker-based method utilizes known cell-specific marker genes to measure
+relative abundances across samples.")
+   (license license:gpl3)))
+
 ;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
 ;; from Bioconductor.
 (define-public r-deconstructsigs
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5617383cbc..93fe44c25c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2838,31 +2838,6 @@  where the bound function accepts additional arguments.")
 bindings that call a C++ function.")
     (license license:expat)))
 
-(define-public r-bisquerna
-  (package
-   (name "r-bisquerna")
-   (version "1.0.4")
-   (source (origin
-            (method url-fetch)
-            (uri (cran-uri "BisqueRNA" version))
-            (sha256
-             (base32
-              "01g34n87ml7n3pck77497ddgbv3rr5p4153ac8ninpgjijlm3jw2"))))
-   (properties `((upstream-name . "BisqueRNA")))
-   (build-system r-build-system)
-   (propagated-inputs
-    `(("r-biobase" ,r-biobase)
-      ("r-limsolve" ,r-limsolve)))
-   (home-page "https://www.biorxiv.org/content/10.1101/669911v1")
-   (synopsis "Decomposition of bulk expression with single-cell sequencing")
-   (description "This package provides tools to accurately estimate cell type
-abundances from heterogeneous bulk expression.  A reference-based method
-utilizes single-cell information to generate a signature matrix and
-transformation of bulk expression for accurate regression based estimates.
-A marker-based method utilizes known cell-specific marker genes to measure
-relative abundances across samples.")
-   (license license:gpl3)))
-
 (define-public r-auc
   (package
     (name "r-auc")