diff mbox series

[bug#47219] gnu: Add snapcast.

Message ID 20210317195855.5557-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#47219] gnu: Add snapcast. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines March 17, 2021, 7:58 p.m. UTC
* gnu/packages/audio.scm (snapcast): New variable.
---
 gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Ludovic Courtès March 19, 2021, 12:49 p.m. UTC | #1
Hi!

Christopher Baines <mail@cbaines.net> skribis:

> * gnu/packages/audio.scm (snapcast): New variable.

LGTM! :-)

Ludo’.
Christopher Baines March 23, 2021, 9:17 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/audio.scm (snapcast): New variable.
>
> LGTM! :-)

Great, I've pushed this as aa13529baf498362b5d0c2310d1349692f71a260.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8b23f04fe5..b873a34857 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1052,6 +1052,40 @@  performances.  The plugins include a cellular automaton synthesizer, an
 envelope follower, distortion effects, tape effects and more.")
     (license license:gpl2+)))
 
+(define-public snapcast
+  (package
+    (name "snapcast")
+    (version "0.24.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/badaix/snapcast")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13yz8alplnqwkcns3mcli01qbyy6l3h62xx0v71ygcrz371l4g9g"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f))                    ; no included tests
+    (inputs
+     `(("boost" ,boost)
+       ("libvorbis" ,libvorbis)
+       ("soxr" ,soxr)
+       ("alsa-lib" ,alsa-lib)
+       ("avahi" ,avahi)
+       ("pulseaudio" ,pulseaudio)
+       ("flac" ,flac)
+       ("opus" ,opus)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/badaix/snapcast")
+    (synopsis "Synchronous multiroom audio player")
+    (description
+     "Snapcast is a multi-room client-server audio player.  Clients are time
+synchronized with the server to play synced audio.")
+    (license license:gpl3+)))
+
 (define-public swh-plugins
   (package
     (name "swh-plugins")