diff mbox series

[bug#47153,v2,2/3] gnu: chez-scheme: Update stex.

Message ID 20210315225302.6597-2-philip@philipmcgrath.com
State Accepted
Headers show
Series [bug#47153,v2,1/3] gnu: chez-scheme: Update nanopass to 1.9.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath March 15, 2021, 10:53 p.m. UTC
Get a patch from upstream that will help us simplify the build process
for the Chez Scheme documentation.

* gnu/packages/chez.scm (chez-stex): Update to commit 5405149.
---
 gnu/packages/chez.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 5dd1185c43..dd0db04d88 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -59,8 +59,12 @@ 
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/dybvig/stex")
-            (commit (string-append "v" version))))
-      (sha256 (base32 "1q5i8pf4cdfjsj6r2k1rih7ljbfggyxdng2p2fvsgarzihpsin2i"))
+            ;; This commit includes a fix for which we would
+            ;; otherwise want to use a snippet.
+            ;; When there's a new tagged release,
+            ;; go back to using (string-append "v" version)
+            (commit "54051494434a197772bf6ca5b4e6cf6be55f39a5")))
+      (sha256 "01jnvw8qw33gnpzwrakwhsr05h6b609lm180jnspcrb7lds2p23d")
       (file-name (git-file-name "stex" version)))))
 
 (define-public chez-scheme