diff mbox series

[bug#44492,v6,05/51] gnu: Add rust-twoway-0.2.

Message ID 20210315171416.14446-5-leo.prikler@student.tugraz.at
State New
Headers show
Series [bug#44492,v6,01/51] gnu: Add rust-ruma-identifiers-validation-0.1. | expand

Commit Message

Leo Prikler March 15, 2021, 5:13 p.m. UTC
* gnu/packages/crates-io.scm (rust-twoway-0.2): New variable.
---
 gnu/packages/crates-io.scm | 39 ++++++++++++++++++++++++++++++--------
 1 file changed, 31 insertions(+), 8 deletions(-)

Comments

Efraim Flashner March 16, 2021, 12:43 p.m. UTC | #1
rust-twoway-0.2 and 0.1 use the same cargo-inputs. You can have 0.1
inherit all the arguments from 0.2 if you want.

On Mon, Mar 15, 2021 at 06:13:30PM +0100, Leo Prikler wrote:
> * gnu/packages/crates-io.scm (rust-twoway-0.2): New variable.
> ---
>  gnu/packages/crates-io.scm | 39 ++++++++++++++++++++++++++++++--------
>  1 file changed, 31 insertions(+), 8 deletions(-)
> 
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 78cdc54718..91bcbacfae 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -45873,8 +45873,38 @@ design abstracts away all the internals of the WebSocket protocol but still
>  makes them accessible for those who wants full control over the network.")
>      (license (list license:expat license:asl2.0))))
>  
> +(define-public rust-twoway-0.2
> +  (package
> +    (name "rust-twoway")
> +    (version "0.2.1")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (crate-uri "twoway" version))
> +        (file-name
> +          (string-append name "-" version ".tar.gz"))
> +        (sha256
> +          (base32
> +            "1g55kf4rx0q682fvzxdixqihmlbamn5ms2yqvcm92fny21chfh3b"))))
> +    (build-system cargo-build-system)
> +    (arguments
> +      `(#:skip-build? #t
> +        #:cargo-inputs
> +        (("rust-galil-seiferas" ,rust-galil-seiferas-0.1)
> +         ("rust-jetscii" ,rust-jetscii-0.3)
> +         ("rust-memchr" ,rust-memchr-2)
> +         ("rust-unchecked-index"
> +          ,rust-unchecked-index-0.2))))
> +    (home-page "https://github.com/bluss/twoway")
> +    (synopsis "Fast substring search for strings and byte strings")
> +    (description
> +     "This package provides a fast substring search for strings and byte
> +strings.")
> +    (license (list license:expat license:asl2.0))))
> +
>  (define-public rust-twoway-0.1
>    (package
> +    (inherit rust-twoway-0.2)
>      (name "rust-twoway")
>      (version "0.1.8")
>      (source
> @@ -45884,20 +45914,13 @@ makes them accessible for those who wants full control over the network.")
>         (file-name (string-append name "-" version ".tar.gz"))
>         (sha256
>          (base32 "1lbf64snscr3vz71jbl6i2c8zr2ndsiqbk6316z39fj1a8mipcar"))))
> -    (build-system cargo-build-system)
>      (arguments
>       `(#:skip-build? #t
>         #:cargo-inputs
>         (("rust-galil-seiferas" ,rust-galil-seiferas-0.1)
>          ("rust-jetscii" ,rust-jetscii-0.3)
>          ("rust-memchr" ,rust-memchr-2)
> -        ("rust-unchecked-index" ,rust-unchecked-index-0.2))))
> -    (home-page "https://github.com/bluss/twoway")
> -    (synopsis "Fast substring search for strings and byte strings")
> -    (description
> -     "This package provides a fast substring search for strings and byte
> -strings.")
> -    (license (list license:expat license:asl2.0))))
> +        ("rust-unchecked-index" ,rust-unchecked-index-0.2))))))
>  
>  (define-public rust-typeable-0.1
>    (package
> -- 
> 2.30.2
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 78cdc54718..91bcbacfae 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45873,8 +45873,38 @@  design abstracts away all the internals of the WebSocket protocol but still
 makes them accessible for those who wants full control over the network.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-twoway-0.2
+  (package
+    (name "rust-twoway")
+    (version "0.2.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "twoway" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1g55kf4rx0q682fvzxdixqihmlbamn5ms2yqvcm92fny21chfh3b"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build? #t
+        #:cargo-inputs
+        (("rust-galil-seiferas" ,rust-galil-seiferas-0.1)
+         ("rust-jetscii" ,rust-jetscii-0.3)
+         ("rust-memchr" ,rust-memchr-2)
+         ("rust-unchecked-index"
+          ,rust-unchecked-index-0.2))))
+    (home-page "https://github.com/bluss/twoway")
+    (synopsis "Fast substring search for strings and byte strings")
+    (description
+     "This package provides a fast substring search for strings and byte
+strings.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-twoway-0.1
   (package
+    (inherit rust-twoway-0.2)
     (name "rust-twoway")
     (version "0.1.8")
     (source
@@ -45884,20 +45914,13 @@  makes them accessible for those who wants full control over the network.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1lbf64snscr3vz71jbl6i2c8zr2ndsiqbk6316z39fj1a8mipcar"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-galil-seiferas" ,rust-galil-seiferas-0.1)
         ("rust-jetscii" ,rust-jetscii-0.3)
         ("rust-memchr" ,rust-memchr-2)
-        ("rust-unchecked-index" ,rust-unchecked-index-0.2))))
-    (home-page "https://github.com/bluss/twoway")
-    (synopsis "Fast substring search for strings and byte strings")
-    (description
-     "This package provides a fast substring search for strings and byte
-strings.")
-    (license (list license:expat license:asl2.0))))
+        ("rust-unchecked-index" ,rust-unchecked-index-0.2))))))
 
 (define-public rust-typeable-0.1
   (package