diff mbox series

[bug#47156,05/10] gnu: r-s4vectors: Move to (gnu packages bioconductor).

Message ID 20210315130134.30302-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 15, 2021, 1:01 p.m. UTC
* gnu/packages/bioinformatics.scm (r-s4vectors): Move from here...
* gnu/packages/bioconductor.scm (r-s4vectors): ...to here.
---
 gnu/packages/bioconductor.scm   | 28 ++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 27 ---------------------------
 2 files changed, 28 insertions(+), 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 7c97e52312..ed34a9308a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019, 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
@@ -9154,6 +9155,33 @@  generated.")
 routines.")
     (license license:lgpl2.0+)))
 
+(define-public r-s4vectors
+  (package
+    (name "r-s4vectors")
+    (version "0.28.1")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "S4Vectors" version))
+              (sha256
+               (base32
+                "0fhf4lsfxrim7glazh6ng46ykzaly5ggwpg170vcz4cc24prv0rh"))))
+    (properties
+     `((upstream-name . "S4Vectors")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)))
+    (home-page "https://bioconductor.org/packages/S4Vectors")
+    (synopsis "S4 implementation of vectors and lists")
+    (description
+     "The S4Vectors package defines the @code{Vector} and @code{List} virtual
+classes and a set of generic functions that extend the semantic of ordinary
+vectors and lists in R.  Package developers can easily implement vector-like
+or list-like objects as concrete subclasses of @code{Vector} or @code{List}.
+In addition, a few low-level concrete subclasses of general interest (e.g.
+@code{DataFrame}, @code{Rle}, and @code{Hits}) are implemented in the
+S4Vectors package itself.")
+    (license license:artistic2.0)))
+
 ;; This is a CRAN package, but it depends on preprocessorcore, which is a
 ;; Bioconductor package.
 (define-public r-wgcna
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d8d64818d2..1fcb436f0d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,33 +7691,6 @@  including VCF header and contents in RDF and JSON.")
     (home-page "https://github.com/vcflib/bio-vcf")
     (license license:expat)))
 
-(define-public r-s4vectors
-  (package
-    (name "r-s4vectors")
-    (version "0.28.1")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "S4Vectors" version))
-              (sha256
-               (base32
-                "0fhf4lsfxrim7glazh6ng46ykzaly5ggwpg170vcz4cc24prv0rh"))))
-    (properties
-     `((upstream-name . "S4Vectors")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biocgenerics" ,r-biocgenerics)))
-    (home-page "https://bioconductor.org/packages/S4Vectors")
-    (synopsis "S4 implementation of vectors and lists")
-    (description
-     "The S4Vectors package defines the @code{Vector} and @code{List} virtual
-classes and a set of generic functions that extend the semantic of ordinary
-vectors and lists in R.  Package developers can easily implement vector-like
-or list-like objects as concrete subclasses of @code{Vector} or @code{List}.
-In addition, a few low-level concrete subclasses of general interest (e.g.
-@code{DataFrame}, @code{Rle}, and @code{Hits}) are implemented in the
-S4Vectors package itself.")
-    (license license:artistic2.0)))
-
 (define-public r-iranges
   (package
     (name "r-iranges")