diff mbox series

[bug#47082] gnu: Add dragon-drop

Message ID 20210312012620.3255-1-yoavm448@gmail.com
State Accepted
Headers show
Series [bug#47082] gnu: Add dragon-drop | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Yoav Marco March 12, 2021, 1:26 a.m. UTC
* gnu/packages/gtk.scm (dragon-drop): New variable.
---

I didn't manage to test the Guix repo even without my changes, but the package
works when adding "dragon-drop" at the end of the file and installing with
"guix package -f".

 gnu/packages/gtk.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Ludovic Courtès March 19, 2021, 12:58 p.m. UTC | #1
Hi Yoav,

Yoav Marco <yoavm448@gmail.com> skribis:

> * gnu/packages/gtk.scm (dragon-drop): New variable.

Pushed with minor indentation tweaks and Texinfo markup for the
description.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b9e81c9..33345e8 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2063,6 +2063,47 @@  shell scripts.  Example of how to use @code{yad} can be consulted at
 @url{https://sourceforge.net/p/yad-dialog/wiki/browse_pages/}.")
     (license license:gpl3+)))
 
+(define-public dragon-drop
+  (package
+   (name "dragon-drop")
+   (version "1.1.1")
+   (source
+    (origin
+     (method git-fetch)
+     (uri
+      (git-reference
+       (url "https://github.com/mwh/dragon.git")
+       (commit (string-append "v" version))))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "0fgzz39007fdjwq72scp0qygp2v3zc5f1xkm0sxaa8zxm25g1bra"))))
+   (build-system gnu-build-system)
+   (inputs `(("gtk+" ,gtk+)))
+   (native-inputs `(("pkg-config" ,pkg-config)))
+   (arguments
+    `(#:tests? #f                       ; no check
+      #:make-flags
+      (list (string-append "CC=" ,(cc-for-target))
+            ;; makefile uses PREFIX for the binary location
+            (string-append "PREFIX="
+                           (assoc-ref %outputs "out")
+                           "/bin"))
+      #:phases
+      (modify-phases %standard-phases
+                     (delete 'configure)))) ; no configure script
+   (synopsis "Drag and drop source/target for X")
+   (description
+    "dragon is a lightweight drag-and-drop source for X where you can run:
+  dragon file.tar.gz
+to get a window with just that file in it, ready to be dragged where you need it.
+What if you need to drag into something? Using:
+  dragon --target
+you get a window you can drag files and text into.  Dropped items are
+printed to standard output.")
+   (home-page "https://github.com/mwh/dragon")
+   (license license:gpl3+)))
+
 (define-public libdbusmenu
   (package
     (name "libdbusmenu")