diff mbox series

[bug#42885,25/27] gnu: calibre: Add qtsvg as input.

Message ID 20210310090053.21612-25-mail@brendan.scot
State Accepted
Headers show
Series [bug#42885,01/27] gnu: python-sip: Update to 5.5.0. Add python-sip-4 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley March 10, 2021, 9 a.m. UTC
* gnu/packages/ebook.scm (calibre):[inputs]: Add qtsvg as an input.

This fixes part of the broken qt test, but not all. It still fails
printing to pdf.
---
 gnu/packages/ebook.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index be367a5245..25a31c9a65 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -199,6 +199,7 @@ 
        ("python-regex" ,python-regex)
        ("python-speechd" ,speech-dispatcher)
        ("python-zeroconf" ,python-zeroconf)
+       ("qtsvg" ,qtsvg)
        ("qtwebengine" ,qtwebengine)
        ("sqlite" ,sqlite)))
     (arguments
@@ -277,9 +278,8 @@  sip-include-dirs = [\"" pyqt "/share/sip" "\"]")))
               ;; This informs the tests we are a continuous integration
               ;; environment and thus have no networking.
               (setenv "CI" "true")
-              ;; The Qt test complains about being unable to load all image plugins, and I
-              ;; notice the available plugins list it shows lacks 'svg'. Adding qtsvg doesn't
-              ;; fix it, so I'm not sure how to fix it.  TODO: Fix test and remove this.
+              ;; The Qt test fails at printing to pdf:
+              ;; AssertionError: b'Skia/PDF' not found in b'' : Print to PDF failed
               (setenv "SKIP_QT_BUILD_TEST" "true")
               #t)))
          (add-after 'build 'build-extra