diff mbox series

[bug#47010,07/10] gnu: r-category: Move to (gnu packages bioconductor).

Message ID 20210308175802.62517-7-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 8, 2021, 5:58 p.m. UTC
* gnu/packages/bioinformatics.scm (r-category): Move from here...
* gnu/packages/bioconductor.scm (r-category): ...to here.
---
 gnu/packages/bioconductor.scm   | 31 +++++++++++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 31 -------------------------------
 2 files changed, 31 insertions(+), 31 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a17c6beeef..4e3dd25d61 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1519,6 +1519,37 @@  microarrays.")
 databases.  Packages produced are intended to be used with AnnotationDbi.")
     (license license:artistic2.0)))
 
+(define-public r-category
+  (package
+    (name "r-category")
+    (version "2.56.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "Category" version))
+       (sha256
+        (base32
+         "0m77wpnica0h2ia9ajdaiga4plgz1s9wls6pdnxzk7kwl8a68wkr"))))
+    (properties `((upstream-name . "Category")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotate" ,r-annotate)
+       ("r-annotationdbi" ,r-annotationdbi)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-genefilter" ,r-genefilter)
+       ("r-graph" ,r-graph)
+       ("r-gseabase" ,r-gseabase)
+       ("r-matrix" ,r-matrix)
+       ("r-rbgl" ,r-rbgl)
+       ("r-dbi" ,r-dbi)))
+    (home-page "https://bioconductor.org/packages/Category")
+    (synopsis "Category analysis")
+    (description
+     "This package provides a collection of tools for performing category
+analysis.")
+    (license license:artistic2.0)))
+
 (define-public r-deseq2
   (package
     (name "r-deseq2")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 23b8ce6892..6b32f3416c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7385,37 +7385,6 @@  includes software to
 ")
       (license license:cc0))))
 
-(define-public r-category
-  (package
-    (name "r-category")
-    (version "2.56.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "Category" version))
-       (sha256
-        (base32
-         "0m77wpnica0h2ia9ajdaiga4plgz1s9wls6pdnxzk7kwl8a68wkr"))))
-    (properties `((upstream-name . "Category")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-annotate" ,r-annotate)
-       ("r-annotationdbi" ,r-annotationdbi)
-       ("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-genefilter" ,r-genefilter)
-       ("r-graph" ,r-graph)
-       ("r-gseabase" ,r-gseabase)
-       ("r-matrix" ,r-matrix)
-       ("r-rbgl" ,r-rbgl)
-       ("r-dbi" ,r-dbi)))
-    (home-page "https://bioconductor.org/packages/Category")
-    (synopsis "Category analysis")
-    (description
-     "This package provides a collection of tools for performing category
-analysis.")
-    (license license:artistic2.0)))
-
 (define-public r-gostats
   (package
     (name "r-gostats")