diff mbox series

[bug#47010,05/10] gnu: r-rbgl: Move to (gnu packages bioconductor).

Message ID 20210308175802.62517-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Move some Bioconductor packages to (gnu packages bioconductor). | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 8, 2021, 5:57 p.m. UTC
* gnu/packages/bioinformatics.scm (r-rbgl): Move from here...
* gnu/packages/bioconductor.scm (r-rbgl): ...to here.
---
 gnu/packages/bioconductor.scm   | 23 +++++++++++++++++++++++
 gnu/packages/bioinformatics.scm | 23 -----------------------
 2 files changed, 23 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 706b87b207..0a9dc4f9ba 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1650,6 +1650,29 @@  high-throughput sequencing experiments.")
 the Human Protein Atlas project.")
     (license license:artistic2.0)))
 
+(define-public r-rbgl
+  (package
+    (name "r-rbgl")
+    (version "1.66.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "RBGL" version))
+       (sha256
+        (base32
+         "016vyzgixb3gjpzi21rbs6ngnnqcxr77krwjjf1ldnzzj8vqrqsz"))))
+    (properties `((upstream-name . "RBGL")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bh" ,r-bh)
+       ("r-graph" ,r-graph)))
+    (home-page "https://www.bioconductor.org/packages/RBGL")
+    (synopsis "Interface to the Boost graph library")
+    (description
+     "This package provides a fairly extensive and comprehensive interface to
+the graph algorithms contained in the Boost library.")
+    (license license:artistic2.0)))
+
 (define-public r-regioner
   (package
     (name "r-regioner")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3212641af9..0f96ffc02e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7385,29 +7385,6 @@  includes software to
 ")
       (license license:cc0))))
 
-(define-public r-rbgl
-  (package
-    (name "r-rbgl")
-    (version "1.66.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "RBGL" version))
-       (sha256
-        (base32
-         "016vyzgixb3gjpzi21rbs6ngnnqcxr77krwjjf1ldnzzj8vqrqsz"))))
-    (properties `((upstream-name . "RBGL")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-bh" ,r-bh)
-       ("r-graph" ,r-graph)))
-    (home-page "https://www.bioconductor.org/packages/RBGL")
-    (synopsis "Interface to the Boost graph library")
-    (description
-     "This package provides a fairly extensive and comprehensive interface to
-the graph algorithms contained in the Boost library.")
-    (license license:artistic2.0)))
-
 (define-public r-gseabase
   (package
     (name "r-gseabase")