diff mbox series

[bug#46996] gnu: Add emacs-tup-mode.

Message ID 20210307215741.477828-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46996] gnu: Add emacs-tup-mode. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör March 7, 2021, 9:57 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-tup-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou March 7, 2021, 11:16 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/emacs-xyz.scm (emacs-tup-mode): New variable.

Applied. Thank you.

> +(define-public emacs-tup-mode
> +  (package
> +    (name "emacs-tup-mode")
> +    (version "1.3.1")
> +    (home-page "https://github.com/ejmr/tup-mode")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url home-page)

Nitpick: I'm not a big fan of this hack, since modifying the home-page
can break the build. So I moved it changed it.

> +    (synopsis "An Emacs major mode for editing Tup files")

I changed the synopsis so it does not start with "An" anymore (see "guix
lint")

> +    (description
> +     "Major mode for Emacs made for editing ‘tupfiles’.  These are files used
> +by the Tup build system.")

I used full sentences for the description.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 960a5668ca..21713dbf79 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -94,6 +94,7 @@ 
 ;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
 ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5313,6 +5314,27 @@  view the build status of those servers' build jobs, and possibly to trigger
 build jobs.")
     (license license:gpl3+)))
 
+(define-public emacs-tup-mode
+  (package
+    (name "emacs-tup-mode")
+    (version "1.3.1")
+    (home-page "https://github.com/ejmr/tup-mode")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0asd024n5v23wdsg1959sszq568wg3a1bp4jrk0cllfji1z0n78y"))))
+    (build-system emacs-build-system)
+    (synopsis "An Emacs major mode for editing Tup files")
+    (description
+     "Major mode for Emacs made for editing ‘tupfiles’.  These are files used
+by the Tup build system.")
+    (license license:gpl3+)))
+
 (define-public emacs-company
   (package
     (name "emacs-company")