diff mbox series

[bug#46449] gnu: Add python-mistletoe.

Message ID 20210307212125.241574-1-noisytoot@disroot.org
State Accepted
Headers show
Series [bug#46449] gnu: Add python-mistletoe. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ron Nazarov March 7, 2021, 9:21 p.m. UTC
* gnu/packages/markup.scm (python-mistletoe): New variable.
---
 gnu/packages/markup.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Tobias Geerinckx-Rice March 8, 2021, 7:01 p.m. UTC | #1
Toot,

Ron Nazarov via Guix-patches via 写道:
> * gnu/packages/markup.scm (python-mistletoe): New variable.

Thanks!  Pushed as 80599a739d04fb1830ee0169256021764784e850, with 
minor changes:

> +    (synopsis "Fast, extensible Markdown parser in pure 
> Python")
                  ^^^^
I removed this, since all software is now fast, light-weight, and 
well-written.  It's the law or something.

> +    (description

I wrapped this to 80 characters.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 95a3eb269e..4e0fcdce1c 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,6 +32,7 @@ 
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system python)
   #:use-module (guix utils)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages)
@@ -300,3 +302,24 @@  and smu is that smu doesn't support reference style links.")
 SAX-like interface.  It is compliant to the CommonMark specification,
 with a few extensions.")
     (license expat)))
+
+(define-public python-mistletoe
+  (package
+    (name "python-mistletoe")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mistletoe" version))
+       (sha256
+        (base32 "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/miyuchina/mistletoe")
+    (synopsis "Fast, extensible Markdown parser in pure Python")
+    (description
+     "The @code{mistletoe} Markdown parser is a CommonMark-compliant Markdown parser
+that supports definitions of custom tokens.
+Parsing Markdown into an abstract syntax tree also allows @code{mistletoe}
+to swap out renderers for different output formats,
+without touching any of the core components.")
+    (license expat)))