diff mbox series

[bug#46987] gnu: rust-1.19: Don't include i686-linux in supported-systems.

Message ID 20210307133406.17656-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#46987] gnu: rust-1.19: Don't include i686-linux in supported-systems. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines March 7, 2021, 1:34 p.m. UTC
Currently rust fails to build for i686-linux, so this will avoid computing
lots of derivations that depend on rust, but won't be possible to build.

* gnu/packages/rust.scm (rust-1.19)[supported-systems]: Switch hardcoding only
supporting x86_64-linux for supporting all supported systems, other than
i686-linux.
---
 gnu/packages/rust.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Christopher Baines March 8, 2021, 10:35 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> Currently rust fails to build for i686-linux, so this will avoid computing
> lots of derivations that depend on rust, but won't be possible to build.
>
> * gnu/packages/rust.scm (rust-1.19)[supported-systems]: Switch hardcoding only
> supporting x86_64-linux for supporting all supported systems, other than
> i686-linux.
> ---
>  gnu/packages/rust.scm | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
> index 98a6bfffa5..1fc540f0f8 100644
> --- a/gnu/packages/rust.scm
> +++ b/gnu/packages/rust.scm
> @@ -453,7 +453,9 @@ test = { path = \"../libtest\" }
>              (variable "LIBRARY_PATH")
>              (files '("lib" "lib64")))))
>
> -    (supported-systems '("x86_64-linux"))
> +    (supported-systems
> +     (delete "i686-linux"               ; fails to build, see #35519
> +             %supported-systems))
>      (synopsis "Compiler for the Rust programming language")
>      (description "Rust is a systems programming language that provides memory
>  safety and thread safety guarantees.")

I've gone ahead and pushed this to master as
f5c6e6966c020722700ef0343ab0a6030e2d61b5.
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 98a6bfffa5..1fc540f0f8 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -453,7 +453,9 @@  test = { path = \"../libtest\" }
             (variable "LIBRARY_PATH")
             (files '("lib" "lib64")))))
 
-    (supported-systems '("x86_64-linux"))
+    (supported-systems
+     (delete "i686-linux"               ; fails to build, see #35519
+             %supported-systems))
     (synopsis "Compiler for the Rust programming language")
     (description "Rust is a systems programming language that provides memory
 safety and thread safety guarantees.")