diff mbox series

[bug#46953] gnu: Add xzgv.

Message ID 20210305214642.119232-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46953] gnu: Add xzgv. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör March 5, 2021, 9:46 p.m. UTC
* gnu/packages/image-viewers.scm (xzgv): New variable.
---
 gnu/packages/image-viewers.scm | 38 ++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Nicolas Goaziou March 7, 2021, 11:08 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/image-viewers.scm (xzgv): New variable.

Applied. Thank you.

> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "mirror://sourceforge/xzgv/"
> +                                  version "/" name "-" version ".tar.gz"))

Nitpick: we usually hard-code name here. So did I.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index bddf86568c..8fa6743020 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -748,3 +749,40 @@  allows creating false color images.  A unique feature of Nomacs is the
 synchronization of multiple instances.")
     (home-page "https://nomacs.org/")
     (license license:gpl3+)))
+
+(define-public xzgv
+  (package
+    (name "xzgv")
+    (version "0.9.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/xzgv/"
+                                  version "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "17l1xr9v07ggwga3vn0z1i4lnwjrr20rr8z1kjbw71aaijxl18i5"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-target-directory
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "config.mk"
+               (("/usr/local") (assoc-ref outputs "out")))))
+         (delete 'configure)                     ; no configure script
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
+               (install-file "src/xzgv" bin))))) ; just install the executable
+       #:tests? #f))                             ; no rule for target 'test'
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gtk+" ,gtk+-2)
+       ("libexif" ,libexif)))
+    (synopsis "Picture viewer for X with a thumbnail-based selector")
+    (description
+     "xzgv is a fast image viewer that provides extensive keyboard support.")
+    (home-page "https://sourceforge.net/projects/xzgv/")
+    (license license:gpl2+)))