diff mbox series

[bug#46950] gnu: vim-full: Remove duplicate 'make-flags'.

Message ID 20210305192423.50766-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#46950] gnu: vim-full: Remove duplicate 'make-flags'. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier March 5, 2021, 7:24 p.m. UTC
Fixes <https://bugs.gnu.org/46580>.

* gnu/packages/vim.scm (vim-full): [arguments]: Remove duplicate 'make-flags'.
---
 gnu/packages/vim.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)


base-commit: b2a94e59b8fba2f43fbefc45c2f1c4caeabdedb1

Comments

Tobias Geerinckx-Rice March 6, 2021, 12:30 a.m. UTC | #1
Pushed as c8cbd369eb512b0bc5cc0d5dfc2b5d35da50aa4f with minor ‘[’ 
tweak and removed out-of-place comment.

Thanks for the swift fix!

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 372d470e09..2202788ee3 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019, 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -216,11 +217,14 @@  with the editor vim.")))
              "--enable-xim"
              "--disable-selinux"
              "--enable-gui")
-       ;; This flag fixes the following error:
-       ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
-       ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
-       #:make-flags '("LDFLAGS=-lexpat")
        ,@(substitute-keyword-arguments (package-arguments vim)
+           ;; This flag fixes the following error:
+           ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
+           ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
+           ((#:make-flags flags)
+            `(append
+              (list "LDFLAGS=-lexpat")
+              (delete "CFLAGS=-D_REENTRANT" ,flags))) ; Fix <https://bugs.gnu.org/46580>.
            ((#:phases phases)
             `(modify-phases ,phases
                (add-before 'check 'start-xserver