diff mbox series

[bug#46946,2/2] gnu: Add python-cooltools.

Message ID 20210305141930.28787-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#46946,1/2] gnu: Add python-bioframe. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu March 5, 2021, 2:19 p.m. UTC
* gnu/packages/bioinformatics.scm (python-cooltools): New variable.
---
 gnu/packages/bioinformatics.scm | 45 +++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index fb357b8b6c..a6ea8f831d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13652,6 +13652,51 @@  storage format, called @code{cool}, used to store genomic interaction data,
 such as Hi-C contact matrices.")
     (license license:bsd-3)))
 
+(define-public python-cooltools
+;;pypi sources requiere bioframe<0.1 while github latest version requires
+;; bioframe>=0.1.0
+  (let ((revision "1")
+        (commit "53ce4fc11d046e84ca36f3591e9e5d548de9f7b2"))
+    (package
+      (name "python-cooltools")
+      (version (git-version "0.3.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+              (url "https://github.com/open2c/cooltools")
+              (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0y1wf7a0by2kih2iy5xrwzdgw1i24cwigfz4352aq5npxrpjvj6q"))))
+      (build-system python-build-system)
+      (propagated-inputs
+       `(("python-bioframe" ,python-bioframe)
+         ("python-click" ,python-click)
+         ("python-cooler" ,python-cooler)
+         ("python-cytoolz" ,python-cytoolz)
+         ("python-joblib" ,python-joblib)
+         ("python-matplotlib" ,python-matplotlib)
+         ("python-multiprocess" ,python-multiprocess)
+         ("python-numba" ,python-numba)
+         ("python-numpy" ,python-numpy)
+         ("python-pandas" ,python-pandas)
+         ("python-scikit-learn" ,python-scikit-learn)
+         ("python-scipy" ,python-scipy)
+         ("python-tables" ,python-tables)))
+      (native-inputs
+       `(("python-cython" ,python-cython)))
+      (home-page
+       "https://github.com/open2c/cooltools")
+      (synopsis
+       "Analysis tools for genomic interaction data stored in .cool format")
+      (description
+       "This package provides necessary tools for the analysis of the genomic
+interaction data stored in .cool format.  This collection of tools includes
+operations like compartment, insulation or peak calling.")
+      (license license:expat))))
+
 (define-public python-hicmatrix
   (package
     (name "python-hicmatrix")